Which activities do not work in unattended robot deployed on virtual machine

I just created a robot on my machine and deployed it on cloud based virtual machine through orchestrator… But the robot created problems in executing some of the activities (like Element Exists Activity) even though I had turned on simulate click on them…
So in case, I wanted to know which activities do not work in such robot deployed on virtual machine (Cloud based)…
Any help will be appreciated!

1 Like

Well Element Exists usually does not fail unless the selector is wrong.

Usually SimulateClick, SimulateType and SendWindowMessages work inside of the VM if the Robot is running inside of the VM as well.

Do you know if your application needs to be for some reason visible on the screen for the Robot to work properly?

Hey @rpavanguard
thanks alot for responding.
I had tried running the robot while screen is visible and while it is not and in both cases ELement Exists activity fails…
And yeah, the selector is working fine, I had verified it via Highlighting and it highlights correct element…

So, Do you mean that there is none of the activities that do not run on virtual machine? even when it is not connected to RDP?

Hi @Asadullah_memon,
We run at least 12 Attended Bots with the RDP screen open. We have the UiPath Assistant installed inside of the machine that is accessible via RDP. Therefore we have not encountered any issues thus far. Is this how you are running your set up?

But we had a problem just like yours with Simulate Click when we were running a Salesforce Automation inside of a PiP Window.

We changed that to SendWindowMessages and set SimulateClick to null and it is working inside PiP now.

Yes @rpavanguard I had even tried running it in the same i.e attended way.

I donot think Element Exists had any simulate click or sendWindowMessages option (apologize if it had cause Iam learner).

And yeah robot is made to work within browser window and I had even installed chrome extension. Can this cause problem?

The options are on a Click or Type Activity not on ElementExists.

If the ElementExists is not working, something in the selector is changing . You will need to compare the selector in the error message with the one that you have put in your design. Believe me, things can be crazy and unexpected.

Have you enabled the Incognito Mode and FileUrl options in the plugin on your VM?
And do you have the latest UiPath System packages updated to their latest versions?


Hi @rpavanguard

Actually I had made the robot to run some of the activities if that Element Exists and if not then navigate to another URL. So, it is actually not causing errors but the process is always uncompleted.

I can try enabling Incognito Mode but Can you please Explain what FileUrl mean?

Hi @Asadullah_memon,

Another alternative is to use the Retry Scope activity and use the Element exists resulting boolean as condition.

  1. Here you could specify a number of retry, the robot will then catct the failed attempt and try again until the given number of retries or until the robot finds the element.

  2. Also before you use element exists it best to also check if the element is properly loaded / is interactive in the properties before checking for element exists or clicking.

  3. Some elements can be very picky in html. They like to be hovered upon first before acting, but in your case the element are not identified in the first place so this must not be an issue.


Here is the setting for the Chrome Plugin


@Asadullah_memon Does the browser is responding properly?

Because by default EE will wait for 30sec to find the element in the browser, so it will fail if the browser element is not activated within that time.

After failing you’re trying to change the selector, so maybe at that time, the element got activated so EE is working fine.

Give it a try with increasing the TimeOut(ms) value for EE activity.