Where to find the InitAllApplication part?

Hello everyone!

im currently sitting on the advanced UiPath course: RPA Developer Advanced (v2020.10)

Sadly, im stuck with something in the first assesment within that course. But i can’t find what im searching. Anybody knows where within the course it is explained how to make those “open/close” files you invoke in the InitAllApplications.xaml file?

I have an error that occurs when I wanna use the config file by going with

in_config("").ToString

I always get the error “Invoke Workflow File: Object reference not set to an instance of an object.” when I start the InitAllApplication file and I don’t get why. So I searched for the video within the course that explains the open/close files and also how to use the in_config part.

I know I saw that stuff before in the videos but I don’t remember where and I can’t find it anymore.

Greetings Mahrie :bear:

Hello,

I don’t quite understand what you mean by “open/close”.

Do you have the problem when trying to use the configuration file?

This file is loaded inside the main in the “InitAllSettings” activity, after executing it, all the settings in the file are passed to a dictionary variable called “Config”.

This variable is passed inside the different workflow files as a parameter, “in_Config”. Inside InitAllApplications for example, it will be called like this, “in_Config”

You have to modify the Config file also with the different values that you want to put for example, I leave you here mine:


In InitAllApplications, in_Config(“System1_URL”).ToString will return the value https://acme-test.uipath.com/.

Regards

What i mean by “open/close” are the so called files, for example: SHA1Online_open
Which that gets invoked inside the InitAllApplication file.

I did what you described, but I get an error saying: Invoke Workflow File: Object reference not set to an instance of an object.

My config file looks pretty similar to yours. Within the InitAllApplication.xaml, i invoke a file called “System1_open”. As the wanted argument I do this: in_Config(“System1URL”).ToString

I think I found the problem. I had an Error in the Main file, I fixed what I changed over there, and now the in_config(“”).ToString works!

Great! I’m glad you were able to fix it. :grinning_face_with_smiling_eyes:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.