Where is the Take screenshot activity in Studio X? Not there in Studio either?

I’m trying to create a robot that performs the following steps:

  1. Loop through a list of websites in Excel
  2. Open each website in the Chrome browser
  3. Take a screenshot of the website
  4. Save in a folder

I have successfully created this workflow up to the crucial step of taking a screenshot! The Take Screenshot activity doesn’t seem to be available in Studio X?

What I’ve tried

  • I tried switching profiles to Studio Pro and opening my project there. Again, Take Screenshot was not available
  • When I tried working from scratch in Studio Pro, Take Screenshot is there! But I don’t want to have to start my project again because creating it in Studio X was so easy and it doesn’t make sense to create it again the hard way.

If Take Screenshot is available in Studio Pro when I start a project from scratch, why can’t I see it when I open a project which I started in Studio X? And how do I get around this?

Many thanks,



The take screenshot activity is not part of the UiAutomationNext activity package , it is part of the UiAutomation package :wink: So what you can do is take a hybrid approach. More precisely do all the looping and browsing part in StudioX, then include the UiAutomation package as a dependency and open the project in Studio and add the activity where you would want to take the screenshot .


1 Like

Thank you so much Dragos! You have saved me a lot of effort :+1:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.