When run, the bot skips a step "click a button"


While run during design, the execution keeps skipping a step. Any suggestion?


This is kinda strange. What activity are you using that are being skipped? Also, the property “Continue on Error” is checked? If yes, take it off.


Just a simple click “button”

@Lucas.Pimenta if I use that action as a start note, it runs. When I run the whole script, the execution skips that step, but runs until the end.

My guess is that you either have a logical error causing it to skip or there is a Try/Catch surrounding the step which is causing it to jump to the Catch, giving the appearance that it is skipping the step.

I think we will need some visuals like screenshots or the .xaml file uploaded that produces the issue, in order to troubleshoot further. But, typically if something is being skipped like that it is because there is an error being thrown and either the “ContinueOnError” is True or it is surrounded by a Try/Catch, or you have a condition causing it to skip over it like with a Decision or If condition.

If it’s potentially due to a Try/Catch, place the Rethrow activity to catch any errors that occur during troubleshooting.


Another possibility is that the WaitForReady property needs to be changed to ‘COMPLETE’.

Sometimes UiPath simply goes too fast for the program to register that the click occurred, or UiPath thinks something is interactive, but in reality is not ready

Skipping.xaml (95.6 KB)

Any chance, you could take a look at my logic to see what’s wrong. The click button action after “Save as” wouldn’t run.
Skipping.xaml (95.6 KB)

I didn’t notice any problems with your Click Save As step. Can you describe exactly what it does? Like does the mouse move to the button at all but just doesn’t click? Are there any other popups that happen after the click happens? It looks like it should work which is why I’m asking.

I would also worry that your “Select Item” step that selects “Excel Workbook” is wrong. I’ve had issues with selecting that in the past and am wondering if it’s causing the Save As to get stuck. There are some various ways to do the Save dialogue box too, and maybe you can consider other options for typing the filepath in.


@ClaytonM thanks for the feedback. I am open to try to select excel workbook using other way. Any suggestions? I tried to use the hotkey (pgup and enter), but it couldn’t select the right one. This is the only workaround I figured out.

The mouse doesn’t even show and move to “Save” button. But it skips and opens the outlook fine.

I just tried the hotkey to select Excel Workbook. It still does the same thing (skipping clicking save button)

Try running it in debug mode with ‘Highlight Elements’ on. Is it finding the correct element for the save button?