When invoking one workflow, the below error showing

When invoking one workflow, the below error showing.

To resolve the exception, you’ll need to review the XAML code and fix any errors that are preventing the XAML file from being properly loaded.

Hi @Shanmathi .xaml file is fine. individually they are working, but when i invoked one within other it is showing this error. What could be the possible problem?

Hey @Yashobanta_Dash The possible problems could be of
Namespace issues: Make sure that all namespaces referenced in the invoked XAML file are declared in the main XAML file.

Assembly reference issues: Make sure that all required assemblies are referenced in both XAML files.

Missing resources: If any resources such as styles or templates are used in the invoked XAML file, make sure that they are also defined in the main XAML file.

Also make sure that all properties and values are valid in both XAML files.

1 Like

i was invoking a project(windows) in a project(windows legacy). Now after i update the main project to windows same error is not showing. But below error is showing.


Compilation failed or was cancelled.

This is just a simple workflow i am testing just by keeping log messages. no variables defined and bothhave same dependencies

Then the problem could be related to the sequence in which the workflows are executed. Make sure that the invoked workflow is not trying to access an object or a resource before it is created.

Another possible cause of this error could be a compatibility issue between the versions of the dependencies used in both workflows. Make sure that both workflows use the same version of all dependencies.

If none of these solutions work, try to isolate the issue by debugging the code, step by step. This may help you to identify the root cause of the error. @Yashobanta_Dash

@Yashobanta_Dash ,
The Main flow you invoking is it in the same project location or a different Project Location?
If different Project Location, Make it in the Same project location and try it. Also, Change the name Main to Main01 or something else.

tried that all. compatibility is same of version and dependencies.still same error.

1 Like

Hi @Gokul_Jayakumar , it is in different folder,but it should work, as in other projects it is working even if workflows are invoked from other folders.Recently upgraded studio enterprise 2020.4 to 2022.10.4.In older existing workflows it is working even if workflows from other folders are invoked. but recently i am creating new workflows and invoking projects from other folders, it is not working

This compilation did not show up when we invoke legacy workflows within legacy one, even if the invoked workflow is in other folder.But when i invoked legacy workflow within windows and vice-versa, this issue showed up.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.