What exactly deployment settings should be for Community Edition Orchestrator user?

I am very new Community Edition Orchestrator user.

I want to run my robot on remote computer through Orchestrator. (Everything is running perfectly while in debug with highlights)

What exactly my deployment settings should be in Orchestrator? What is the default API key available in deployment settings?

Note: I used Computer Vision Activities to built my Process in Ui Path Studio.

Please please please help.

What exactly this documentation means? It looks very confusing to me. Do i need to do anything?

image

Hi @kashyapvyas

The docs for Orchestrator are for the Enterprise edition, which might make it confusing.

Basically, it is not reliable to run an unattended automation on Community Orchestrator together with Community Studio and Robot. This is due to how robot service works on the Community Edition - it will not allow you to log in into the session on the remote machine unless you are already logged in.
There will also be issues with automating on the locked screen.

Having said all of that, running process from Orchestrator in an attended scenario should be rather easy (with you looking at the screen of the machine running the automation).

Simply connect the robot to your Orchestrator following this tutorial:

And then run your process. I would advise you to go through the Academy trainings - Foundation and Orchestrator to understand the basics.

@loginerror

I think i failed to get you understand my issue. I already successfully connect my robot (development type) to Orchestrator on remote desktop using machine key and Orchestrator URL. And Whenever i am running my job through Orchestrator, remote machine is already logged in (no lock screen) and session is available.


BUT When I starts JOB from Orchestrator, ROBOT (deployed on remote computer) only can able to successfully execute my first activity “Start Process” and then it throws me error “Cannot find the UI element corresponding to this selector”.










BUT IN DEBUG MODE EVERYTHING RUNS PERFECT

When i run same process through Ui Path Studio using debug mode, every activity runs perfectly (it highlights each anchor and tag perfectly in debug with highlights) and whole process executes without any exception.




Apart from all above

  1. WHY can’t i run my development standard robot other activities apart from “Start Process” on remote computer through ORCHESTRATOR? WHY?

  2. Orchestrator Settings -> Deployment tab , should i need to do any settings here?

Community%20Edition

Hi @kashyapvyas -

  1. Please add Take Screenshot and save image activities before CV Screen Scope activity to verify if the application has loaded or not.
  2. If not launched then add image exists activity before CV Scope and give a try.
  3. If it is launched then please keep a copy of the image and run the process again in attended mode.
  4. Right click on the image --> Properties --> Detail and compare the resolutions of both the image.
  5. If the resolution is different then set it in Orchestrator same as attended mode and give a try.

@mahesh.kumar

I already have tried putting 10,000 milliseconds “Delay Before” in CV Scope property to allow enough time to launch the application. (Application takes hardly 2-3 seconds to launch)

I also put “Delay Before” (5000 milliseconds) in Find CV Text and CV Type Into activities as well.

  1. What you mean by attended mode? Attended Robot?
  2. I can’t understand resolution issue, can you please explain?

Thank you.

Please refer to Resolution settings / UiPath.Settings File resolution configuration / runtime resolution - unattended configuration - How To

@mahesh.kumar

I did the changes shown in above documentation but robot is not executing other activities except the first activity “Start Process”. Can you please help me here.

Please help.

Did you check the image resolution after making these changes? If that is same as running in attended mode then I would suggest to try other Ui activities like open any application and clicking or typing something there to isolate if the issue is with Ui elements or CV activity.
(sorry I forgot to clarify - By attended I meant running from studio or robot when you are logged in manually)