Website not getting opened by the Bot

Trying to automate amazon.com, scrapping the details, writing it in a csv file and saving it in the end for future ref. Browser has been opened by the bot. In the title bar search, name ‘amazon.com’ has been typed as automated and got stuck there. Bot is unable to process thereafter. What could be the possible reason? image
Got stuck here.

HI @Binandraj_V_N

Welcome to the community!!!

May I know which activity you are using to type the URL here in the browser?

There are two different reliable ways of doing it.

  1. Use the open browser activity and give the URL in the activity itself
    else
  2. Use open browser activity to open the browser, then use a navigate to activity to navigate to the given URL within an attach browser activity.

May I know the way that you are using to do this? If possible share some screenshots to get a better understanding…

2 Likes

Thank you and appreciate your prompt response. Well, i went with web recording, other that ‘write csv’ in the end i didn’t actually use any other activity. Browser was selected by clicks.

Well, I think you might need to change the workflow to use either of the approach I have mentioned to open the browser and to navigate to the page. It will be much reliable than click activities.

I suppose this is not a virtual machine that you are trying to automate right?

So changing it to these activities will help to get it fixed :smiley:

1 Like

Please see the pop up:

image

This is the starting:

Uploading: image.jpg…

Okay, then let me try that. I will update you. Thank you.

1 Like

@Binandraj_V_N

I just created this for you to give you a glimpse of the two open browser and attach browser activities. It is the second method I explained above. However you can do it with open browser itself.

So check it out as it will help you to change the workflow you generated through recording…

BrowserOpening.xaml (6.0 KB)

1 Like

Thank you so much for that.
Mine again this one popped up!
Took investing.com instead of amazon and tried to scrap a whole table.

Can you share your workflow so that I can have a look to see where it is going wrong?

1 Like

Hi, appreciate your assistance throughout. Please find the attached file:

Crude Oil.xaml (14.0 KB)

@Binandraj_V_N

Hi again… I did some changes to the workflow to correct few things…

Crude Oil.xaml (14.2 KB)

1 Like

Thank you again. Let me execute and see.

Heyy, that worked. Identified the mistakes made in the initial steps. The data scrapping and writing it on CSV file didn’t worked for me. Instead the following error is popping up.

@Binandraj_V_N

Yeah… here it looks like the selector you have is for a browser. But you are using a attach window activity. Attach window activity is used to attach normal desktop application windows, but not for browsers. For the browser, you got to use the attach browser activity. That’s why you are getting that error. So change it to a attach browser and it will work for you. :slight_smile:

Should I do it from the beginning? Or jus need to replace ‘open window’ with ‘open browser’? Tried but couldn’t succeed.

This is how I changed, not sure whether it’s in a right way or not.

You can remove htmlBrowserName from selector. Reason being html attribute changes everytime you run workflow and bot will run into exception.

2 Likes

Heyy that was cool, got the output. Thank you. Appreciate that.

Thank you so much for all the assistance. :slightly_smiling_face:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.