WebAPI.Activities v1.7.0-beta.1500066 Bug?

Is anyone else having problems with the HTTP Request activity in the latest v1.7.0-beta WebAPI.Activities package? I have a bot that was working fine with v1.6.0 but is having issues after I upgraded to the 1.7.0 preview.

My API query is as follows:

When I try that in my browser, it works fine. When I try it with the latest 1.7.0 preview, I get a returned error saying that I need to define resultType as “core” or “lite”. I have no way of seeing what HTTP Request is actually sending, but I suspect there is some kind of truncation that is clipping the “core” at the end of my query string.

Hi @rc2080

Could you maybe use a service like webhook.site to see the response it sends for you on both activity package versions?

It’s an easy way to debug things.

Either way, this looks like a breaking change at first and I’m sure @Tudor_Sandu will be interested to have a look.

Both versions seem to work with webhook.site. I also tried adding increasingly larger spacer texts at the end of the query string to see how much the truncation is. I still get issues even after inserting up to 6 spacer characters and stopped because I did not want to have my bot get flagged by the EuropePMC API server.

Both lines of evidence leads me to think that my initial hypothesis that the query was being truncated is incorrect. Since my query differs from the webhook.site query in the incorporation of “&” in the query string, I wonder if the "&"s are leading to alteration of subsequent characters.

This is my first time using webhook.site. Is there a way to use it to test subsequent strings tagged on the end of their provided query?

I’m not sure I understand it, but in general the site is useful to catch any discrepancies between how let’s say postman sends out a particular request and how it’s sent out via HTTP Request activity.

Please let us know in case the issue is not solved yet though :slight_smile:

I Have the same issue. 1.6.0 works fine, 1.7.0 returns no result.

Hi @Dion

Would you be able to provide more details?


Was this issue resolved on the latest 1.7.0 version of the package? When I tried your query from the first post, it worked for me both on the beta version as well as the latest stable one:


What details do you need? It seems I cannot even update to 1.7.0 right now.

Indeed, that would mean that the team is already investigating if something went wrong there.

You could always give it a test with the preview version to see if it also reproduced the issue in your scenario:

As to what details - the best possible way would be to reproduce the issue on a public website so that we can try it as well. Otherwise, next best would be more details about the result - does it not work at all, or maybe the call returns an unexpected status code?

The result of een http-request is empty, no info at all.

Does the same happen for a simple request, such as GET on https://google.com?

It happens on different endpoints so I guess it does.

Sorry, yes, the issue was on my side. I thought I had replied in a post to say the issue was resolved but the post seems to have disappeared!

The preview actually had fixed the URL-Segments component of the activity that did not used to function at all. I did not realize I still had things in the URL Segments from when I was troubleshooting last year, and it was those URL segments that was causing my problems.

1 Like