Web Recording - Reports run over web with date time parameters are not working

Hi All -
I am running into issues as I sign on into web to generate reports based on parameters.

  • Sign on to 3rd part web app that traces our driver activity.
  • Navigate to reports tab
  • Select Report
  • Pass parameters
  • Select Sites the report need to be run for
  • Pass Date and Time to run Report

My issues is as I pass the Report Data and Time for Start and End timing.

The web recording “Type Into” Activity
Start Date & Time : System.DateTime.Now.AddDays(-1).ToString(“MM/dd/yyyy")+" 05:00:00 AM"
and then again The web recording “Type Into” Activity
End Date & Time : System.DateTime.Now.AddDays(-0).ToString(“MM/dd/yyyy")+" 05:00:00 AM"
Click Input - Generate Report Button

We need to run this report from yesterday 5AM to today 5AM. As soon as I enter Start Date and time and go into End Date and time. The report is resetting back to below and then clicks
Generate Report Button. When I manually type, it has no issue but BOT is doing exact same step as how I am doing but it gets reset. How can the passed date/time parameters stay intact and generates report.

Start Date & Time : System.DateTime.Now.AddDays(-1).ToString(“MM/dd/yyyy")+" 12:00:00 AM"
and then again The web recording “Type Into” Activity
End Date & Time : System.DateTime.Now.AddDays(-0).ToString(“MM/dd/yyyy")+" 11:59:59 PM" as they are the default.
Click Input - Generate Report Button

Hi there…!

I am not exactly sure as to why the data might reset when using uipath but not manually…

But in IE go to internet options → security tab - > custom level-> enable active scripting (worth a try)

Also, try combinations of simulate, default and send windows message properties.

Assign a string variable with the date time conversion and then write that variable in the type into activity.

Also, instead of web recording drag and drop the activity, indicate the selectors and refine them using UiExplorer.

Hope the above steps solve your issue.

Regards :slight_smile:

Yes, IE options are already set , No change required.
Assign to string or direct passing into type into worked similarly. Not required.
Didn’t need to go into seclector/Ui Explorer as of now.

All I had to do is disable or Uncheck Simulate Type under option for “Type Into” activity for both “Start Datetime”/“End Date” and it did the charm. Thanks @Raghavendraprasad for giving me the hint to try combinations. I have tried it earlier with combinations under common/Input/Misc/options but was hesitant to change setting that came as part of web recording. Didn’t fully understand simulate type functionality.

Web%20Type%20into%20activity%20setting

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.