Web recording from csv to Salesforce

studio

#1

Hello,
While I am trying to develop a process were it will take data from csv file to salesforce. The recording process saved successfully however when I run the process the recording fails when a new window pops up while adding contact to the salesforce contact list. Please suggest where I’m making the mistake.


#2

Can you post the screenshots? Is the pop up part of the recording?


#3


#4

After it press to New, the window popup for entering the First Name however the control is not getting there and throwing exceptions and error out


#5

Can you also post what error you are getting,if possible attach your workflow? Most commonly the errors are due to selectors.


#6

Click ‘A javascript:void(0);’ : Cannot find the UI element corresponding to this selector:


#7

Based on the name, error is originating from a URL click mostly New button.

Can you go to properties of that click and go to selectors and paste the contents here


#8

we bctrl id=‘60:2901;a’ tag= ‘INPUT’ />


#9

Looks like selector is dynamic based upon the error and the selector you pasted. you can use a wild card character and give a try

<webctrl id='*;a' tag= 'INPUT' />


#10

Tried this approach but still it wont able to type automatically when the new window pop up for the entry.
I even tried two web recording sequence, one for each window but seems that also not working


#11

Can you share your xaml?


#12

CSVtoSalesforce.xaml (36.3 KB)


#13

What are you doing after clicking new and selecting salutation?

<webctrl parentid='29:2901;a' tag='A' /> --> what does this do?


#14

After that, new window comes up for the entry of new contact, from there onwards the recording is not working as per the setup.


#15

Comment the highlighted one and try once


#16

ok, let me try


#17

do you have the idea about delay in response concept in uipath?


#18

Hello, While I’m reading a pdf and writing on text file , it throw me the below error. can you suggest the solution. I have defined the occurrence as needed.
FirstName LastName Email Account Phone,
FirstName1 LastName1email1@gmail.com account1 2102121,
FirstName2 LastName2email2@gmail.com account2 3103121,
FirstName3 LastName3email3@gmail.com account3 40143254,
FirstName4 LastName4email4@gmail.com account4 501124,
FirstName5 LastName5email5@gmail.com account5 20842534
Assign : Index was outside the bounds of the array.


#19

Your Last Name and email values are not saperated by space,mostly that’s the culprit.


#20

This have been corrected with the use of delay as well as again the selectors assigned to the Live elements.