Web automation - hyperlink not able to b clicked by bot

I m trying to click on a hyperlink but the automation is failing because of hovering on a feild near payment(0)
How to make payment (0) activate and bot can click on this every time it throw selector issue

I think the payment(0) is in disabled state because it has 0 items in it

And also i couldn’t get your query can you elaborate? @sheetal_Bora


So like when trigger bot ideally it shall click on that payment link but the state of web page is it hovers on succeeding claim and couldnt able to identify that payment (0) uip element I tried using activate activity also


You need to click on the Payment (0) ? @sheetal_Bora and you cannot able to click it is it correct? @sheetal_Bora

Ya not able to click as bot is hovering and succedingclaims field

@sheetal_Bora it looks like you are automating on a Salesforce UI, which by experience I would say that it is tricky (selectors have tendencies to change every SF update). Maybe you can try UiPath Salesforce Activities and work on the backend

Have you tried with modern Click activities? @sheetal_Bora

But how to activate this payment (0) ui element in background so that it can be interactive

No @Sudharsan_Ka wats that ?

What I mean is by using UiPath Salesforce Activities you would not need to do clicks in UI. The processes you perform on the UI can be replicated in the backend using a combination of UiPath SF activities like GetRecord, UpdateRecord, InsertRecord and also SOQL to get data


Go to filters in the activity panel-> Enable show modern

Search for Use application/ Browser activity ande then click



Hello @sheetal_Bora

Can you remove the parent id from the selector and keep only the aaname and check it once.


@Sudharsan_Ka its not working