WaitImageAppear activity not working properly

Hello Team,

WaitImageAppear activity was working fine and today it stopped working and not able to find the button on the screen (even though its visible on the screen)

I haven’t changed any selector or anything. Please help


I guess image quality was changed.

Yes, could be. But it working fine till yesterday
Even after improving the accuracy to 1-it doesnt

Whats the workaround here?

1 Like


ANy solution here?

I have seen your earlier post on similar issue
I use ImageAppear because depends on the data loaded or not it will display the button


Is Image Appear Activity is working or not ?

WaitImageAppear(Find Image) was working but suddenly stopped

Are you talking about OnImageAppear?


Is the Application is on Citrix side or what ?

When I run the application from a VDI -waitimageappear doesn’t find the button

and if I run it from Local machine-it works fine



If both UIpath and automating application are in same machine then use Element Exists or On Element Appear Activity.

If both are in different machine then use Image activities like Find Image or WaitImage Appear etc…

I am not logging to any citrix application.

I was using WaitImageAppear and it was working fine for last few months
Suddenly it stopped…

Thanks Lakshman

OnElementAppear works

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.