Wait for Form Task & Review Activity - Robot Allocation

I have an orchestrator process project, to test out long running workflows. I’ve published to orchestrator and I’ve successfully sent the form task to the task queue, open the task form, assign it to myself, and see the form as i’ve designed it. When it’s sent to the task queue, it’s state is displayed as suspended, which is fine. However, when i go into the task and complete the task object, it moves to a user of “Pending Allocation” and a state of “…Resumed”.

I can’t figure out how to allocate a user to it. I’ve launched the process as an attended bot, i haven’t tried using the unattended yet. I would think if i wasn’t to be launching via attended bot, it wouldn’t let me serve it up on my desktop. In short, how do i trigger the bot to start up after the wait for form task has completed?

When i ran this code in debug in studio, i ran it up to the Wait for Form Task & Review activity, I completed the task, then had to hit the Resume button on my studio instance for it to synch up with the task status to move forward.

For the record, this task/form combo is awesome. When i saw the code snippets for tasks (using asynch for each activities), it furthered my excitement. This is really good stuff. Thanks!

A follow up, i’m trying to have the remaining code after a task has been completed to execute. The problem is it’s getting stuck after a task is complete.

I’m getting better at putting in more images etc, hopefully this gives a clearer picture of my problem.

This is what my job queue looks like, the top row reflects a task that i’ve triggered from my desktop to the task queue, before any assignment or completion is done. The second row represents the state of the job after i complete the task:

When publishing a task to the queue, when i view details for the job, it has a tab that displays the trigger it’s waiting for (when task is complete). No trigger exists in the triggers queue in the left panel in orchestrator:
image

For my instances where i complete the task, when i look at the details, no trigger exists.
Pic to prove the state of the task (taskid=10718):

Pic of the state of the job as it now exists in the job queue:

Pic of the detail view of the job
image

Here is what my project has configured **note - i am aware my task object output in the wait for form task and resume is a different variable than my input object, it’s just me tweaking and testing:

Solved

Needed to launch the process using an unattended bot. Just needed to think through it a little longer. Stumble on!