Wait For Document Data Validation Action And Resume: You are not authorized!

Hello everyone I’m facing this issue that I have mentioned in subject,

" Wait For Document Data Validation Action And Resume: You are not authorized! "

I have downloaded the latest version of Uipath.IntelligentOCR.Activities version 6.5.0 then I have faced to this issue.

I have seen many people said they needed to get some permissions but I have already have all permissions and it is working with older versions but I have to change it to the new version not to get any different type of errors,

I especially can not find right solutions on forum.uipath in these days when I ask a question because as far as I get most of people do not use Document Understanding tools,

I hope someone knows the exact answer.

Hello @hamit.dinc-ext!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly
Forum_Staff

I am also facing this issue. Can anyone help if got the resolution.

Hello Hamit,

From a high level it looks like an access issue, have you made sure you are connected to the right orchestrator tenant and you have the correct path defined? It would be helpful if you can share screenshots of create and wait for data validation action center activities.

Also you mentioned that it worked on older versions, what versions are they? Please specify so we can replicate your error.

Thank you.

@hamit.dinc-ext , @SandeepPanchal
Have you resolved this? I’m getting the same issue. old versions are working.
only changes I made are upgrading the following dependencies.

  1. UiPath.IntelligentOCR.Activities 6.0.1 to 6.6.0
  2. UiPath.OCR.Activities 3.6.2 to 3.12.0
  3. UiPath.DocumentUnderstanding.ML.Activities 1.13.2 to 1.18.0

Studio version is 2022.4.5

Thanks,
Thanu Thomas

Hello @thanu.thomas @hamit.dinc-ext

What are the permissions you have used in your Orchestrator for this user?

This is a permission-related issue. Probably we are missing something.

Would you be able to share what permissions and roles you have given?

Hi Lahiru,
Thanks for the reply. The issue arise only after upgrading the 3 packages to latest. the previous version of the process having the older versions of the packages are still working without any issue.
RObot Role is assigned to the robot user. please check the attachment
robot permissions.docx (134.0 KB)

UiPath support has advised to set assign “allow to be automation user” and “automation user” roles to the user/robot. I have cross checked the permissions and the missing one is the “view” permission on “Users”. Issue is resolved after setting this. But the version befor upgrading the packages is definitely working without this permission. I don’t know Why. @Lahiru.Fernando

1 Like

Hi…

Probably they have introduced more controls on the newer version :grinning:

1 Like