Version compatability Studio/Robot/Orchestrator

I know there are some dependencies between the version of the robot and the version of the orchestrator (which should be usually the same). But are there some dependencies between Studio and Robot/Orchestrator? (And if yes where can i finde more about this?)

For example:
Can i use the latest studio (2019-fasttrack or whatever) with an 2018.4.5 orchestrator?

Hi @mwerner,
Here you have the compatibility matrix: