Variable Type Conversion Issue - working with Excel files part 2

First, my question:
In academy course “DataTables and Excel Automation With Studio” video example 2 titled “Video demo - Working with Excel files part 2” Using Classic studio, they have the “Age” variable with “System.double” type and have no issues adding it to an array with string variables. However, I had a conversion error when attempting the same thing.
Their example is below:

I solved the conversion error by adding .tostring after the “age” variable. Why did the video not have to add .tostring ?
My solution below:

Second comment: Thanks for making all this knowledge free!

Third comment: It takes me 2 to 3 times more than the amount of time stated to complete each course. Consider increasing the time for each course.

this is the error message I was recieving:
image

Hi @Janet_S ,

I believe the demo videos in the course are a bit older or using the Older Versions of Studio and you are having most probably the latest version.

In the newer versions we do see this happen (more restriction on type-cast), as an alternate we can use the below as well

new Object() {"",1,True}

In the older/previous versions, we did have it recognised as Object() even though we did not have to explicitly mention or type-cast it.

Do check if you can get hold of the Version used and then we can check it through.

Or Check with a Windows-Legacy Project, when checked with this compatibility, we get the same experience.

1 Like

@supermanPunch You’re right the video was using v2021.10
Thanks for the alternate solution and idea to check windows-legacy.

This worked!
image

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.