Variable or argument is not defined in the current scope- while making selector dynamic

It showing the same error below the attributes. After changing the scope of the variable, save the workflow.

@Sami_Rajput

can you re-indicate the element and send us the screenshot. Don’t change the variable just send a screenshot once the element is indicated.

Regards

already done that also😫

@Sami_Rajput

have you given any default value for that variable?
if not please provide a default value.
Regards

When indicating the element In the selector editor window check the strict selector and uncheck the fuzzy selector and image.
Change the Title attribute with variable in the strict selectors.

when you are passing variable in the attribute check the overwrite option

Hope you understand!!

@mkankatala

Have you given any default value for that variable?

If not please provide a default value for that variable.

Regards

Done tested with default but in vain

@Sami_Rajput

Sorry didn’t get you can you be more specific

Regards

Tried with default value but still same issue

@Sami_Rajput

Is the casing of your variable the same?

When you add variable it selector the name of variable should match exactly even the casing

And in some cases you would see this error but it would still run can you check

Cheers

@Sami_Rajput

Have you passed the default value in this only?

Regards


Have you check the Override default value.

In some times the validate shows wrong and red color, but it works.

nothing works so far😫

Provide what you want to indicate the element. What is the value do you want to store in the companyName variable.

Provide the full explanation then we will get better understanding.

@Sami_Rajput

You have placed the * beside the variable at first so that’s the reason it is showing this error so can you please re-indicate the element and then replace the data in title with the required variable and make sure you pass the default value into that variable.
Make sure only the variable will be placed over there and no other characters are placed beside that.

Just now I have tried and it worked !!

@vrdabberu
Also tried that :tired_face:

@Sami_Rajput

I have just tried and it worked for me

regards

1 Like

@Sami_Rajput bro delete that activity and place the activity, then indicate the element and pass the variable in the attributes in selector options window.
Make sure to check the override default value option when pass variable to selector.

It’s working when doing this, already tried this it worked

1 Like

@mkankatala @vrdabberu
Thanks!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.