Variable or argument is not defined in the current scope- while making selector dynamic

To make a selector dynamic, I am using a variable but getting this issue

Although the variable scope is defined correctly


try changing the scope of that variable form the variable panel and also remove * beside to that variable


Hi @Sami_Rajput

In the title attribute you have passed the variable side of variable there is * symbol. Remove the * symbol and validate and change the variable scope to main sequence.

Hope it helps!!

@vrdabberu @mkankatala

the scope is correct plus removing the * sign is also not making any difference

Yes * is wild card it will allows anything in that. @Sami_Rajput
You passed a variable for the specific data if you pass the wildcard there is no use of using variable.

Already you have passed the variable so no need of the * over there so please send me a screenshot once removing that



Scope is defined correctly also, i have changed that several time for verification

It showing the same error below the attributes. After changing the scope of the variable, save the workflow.


can you re-indicate the element and send us the screenshot. Don’t change the variable just send a screenshot once the element is indicated.


already done that also😫


have you given any default value for that variable?
if not please provide a default value.

When indicating the element In the selector editor window check the strict selector and uncheck the fuzzy selector and image.
Change the Title attribute with variable in the strict selectors.

when you are passing variable in the attribute check the overwrite option

Hope you understand!!


Have you given any default value for that variable?

If not please provide a default value for that variable.


Done tested with default but in vain


Sorry didn’t get you can you be more specific


Tried with default value but still same issue


Is the casing of your variable the same?

When you add variable it selector the name of variable should match exactly even the casing

And in some cases you would see this error but it would still run can you check



Have you passed the default value in this only?


Have you check the Override default value.

In some times the validate shows wrong and red color, but it works.

nothing works so far😫