Variable not defined in current scope of selector

Hi
I am trying to use variable inside selector but i am getting an error viz “variable not defined in current scope”

Hi @Riya_Bansal

First thing is to change the scope of that variable and try to pass the variable in the selector

Regards
Gokul

1 Like

hi can you put a screenshot of your workflow and screenshot of assign variable window ( variable assign scope )

Hi @Achiranga @Gokul001
Attached ss

Have you tried this? @Riya_Bansal

@Gokul001

it is already the sequence should i need to change it to “Do”?

Can you share the error screenshot? @Riya_Bansal

@Gokul001 attached ss

@Riya_Bansal , That is normal i think can you run the process and check it. If the element can able to do the action correctly?

Regards
Gokul

@Gokul001 i tried executing it but it is not able to click on the ui element, hence get break

Did you able to get the value from the variable? Have you tried to process without passing the variable in the selector and it is working ah? @Riya_Bansal

@Gokul001
Prior to clickk i am logging “nameOfInsurance” var value and i am able to get it correctly.(as you can see in ss provided above)
But it is not working, when used in selector.

Hello - Has anyone found a solution to this? I am having the same issue.