Value for a required activity in For Each Row

At a complete loss on this one. Got all my variables declared and global so different sequences in a Flowchart can see it, but getting this weird error:

Error ERROR Validation Error Value for a required activity argument ‘Values’ was not supplied. Main.xaml

UIPath has recently updated so unsure if it’s done something in the background?
If I replicate this in a pre-existing flow, i don’t get the errors either :confused:

I drove this down to the UiPath.System.Activities 22.7.0 Preview version.


1 Like

It’s a weird one isn’t it. Is it simply one of those things and for want of a better reason, it’s just a bug?

What I’ve done is created a copy of the Flow which didn’t have this issue. Deleted everything in there and built this new one.

Doing that and it’s overcome this strange issue:

To replicate the error, I created a empty workflow and used the package manager to make sure I’m on the new Preview version. You get two warnings until you define and use a new datatable object variable.
As usual, this Activity strays from the norm, and the Next object is not a real datarow variable with a scope.

I think you should choose the stable version
Like this



Hello @fred.bullmer

Define the default value of mydt variable is New System.Data.DataTable in the variables panel. Check how it goes

Thank you for reporting this issue. Our team is looking into it.


thanks it worked


If your issue has been resolved. Please mark the appropriate answer so it will help to others as well.


Thanks for replying, but this topic was specifically to look at the Preview version.
We found and reported an issue. UiPath was able to duplicate our findings, and fixed in the next preview.
Mission Accomplished.

1 Like

Thank you for the reply. At it’s core it copies values from an Excel file to a Datatable and then a For Each Row in Datatable, type into a website.

I’ve tried to trouble shoot it and can confirm all the values DO go to a datatable, so the DataTable is not blank.

But it just hands when it comes to the For Each part of it, essentially the For Each doesen’t work.
I had this problem previously as per this link, click here but given UIPath is now recommending Flows are migrated to the new version and also with this not actually producing an error message, I’m at a loss as to why it’s not working.

I do have another Flow which I have upgraded to ‘Windows’ as per the UIPath message and this is working fine