Using New Services Wizard in Studio

Hi ,

I tried using New services wizard and connected to UIPath through POSTMAN API Key .
After connection through new service I can see my Collections and the endpoints which i have created in POSTMAN but not able to click particular endpoints and check the method URLs which i have used in my POSTMAN. While executing i am facing this issue
NewService Execute Error

Connection link
New Service connection

Could anyone please help me out.


Based on the newman - npm it seems that the API call is using a command line for newman.

You may try to add the newman.cmd/newman path in the Studio/Robot System variables → Path

Then restart the machine and retry the behavior.

ok Marian… let me try will update you soon…Thanks for your response

Hi Marian,

In my system environment variables is already added. But still i face the same issue.

Could you please help me the simple example using New Service wizard as well.

Please find the screenshots.



Try in Studio to add the full path of the newman.cmd.

Let us know if worked.

HI Marian,

Could you please tell me know the steps how to add in studio and the full path of the link.


First, find the newman.cmd executable on the Studio machine → Shift + Right click → Copy as path


Example results:


Then edit the JSON or WSDL that you are trying to import into the New Wizard in a Studio Library, and find the mention of the newman. Instead of the newman, provide the full path of the newman executable from the Studio machine (you extracted it one step ago).

Let us know if this worked.

In my machine not able to get this pkiview.msc.

Not able to get how to use New Service wizard using POSTMAN and try to run it in studio


I showed an example of how to extract the path of the file.

pkiview.msc is not the newman executable.

i dont understand what you are trying to say .

I need to find newman.cmd where? can you please tell?

Hi Marian,

I have installed newman.cmd added the same in environment variables but stilli am facing issue .newman.cmd not found in path.

Could you plz help me on this?


Raise a ticket with the Support team.

Thanks for the response.
Could you plz let me know to whom i need to raise UI path support team?


If you have an Enterprise license, you can check this form Contact Technical Support

I don’t have enterprise license code and i am using trial version of enterprise license.