Using 'Click' on application causes it to crash


I’ve tried just about everything I can think of to click a button in a certain application without causing it to crash, but nothing has worked yet.

When I manually click the “Approve” button in the application, it works fine. The application is also cool with a Bot clicking the “Approve” button if there are a low number of rules being approved. (I’ve tried 124 and below.) However, I am trying to test out having the Bot approve 1,900 rules in this application, and it crashes every time, no matter if I use hardware events, window messages, whatever.

I’m using UiPath Studio 22.10, which I know has a memory leak issue, but I’m not sure that is the cause.

Again, this application works when I am not automating against it and when I am automating against it for smaller cases. It’s just crashing when there is a large case to process.

Then you’ll have to code to detect the crash and deal with it. This isn’t a UiPath problem, it’s a problem with the app. If it’s a supported app, I suggest reaching out to the vendor. I also suggest trying to slow down the automation, it’s probably the volume/speed that’s crashing the app.

You are indeed correct. They opened a user story for it, haha.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.