Using CE with a two robots but one robot is acting weird

Both Robots are running on Win2k12R2 fully patched. The first robot is running within an ESX cluster without any issue. The second robot however is acting weird.

I just created this second robot under Virtualbox on my local laptop. This robot I activated fine (basically that is …). It got a license but it doesn’t stay connected. Then it might be re-connected and get its license back. One thing that is weird is the CE Machine this Robot is tied to never updates its installed version. Attempting to run a simple test workflow to this Robot forever stays “Pending”.

I’m going to delete the machine and robot and try creating Win2k12R on VMware Player and see if the Robot behaves better.

Just curious if anyone has seen issues using VirtualBox Windows VMs as Robot VMs ??


The robot agent is much more stable under a new Vmware Player Win2k12R2 VM. It doesn’t lose connectivity.

But … my robot misbehaving issue is still there. The new Machine I defined for this robot is still not updating the Installed Version of Studio like it should.

The Robot linked to this machine is showing up all green:

The robot status on the VM itself is connected and licensed.


On the VM from the Robot Available Processes menu I can download defined processes and run them fine. However, if I define a Job on CE Orchestrator for that Robot VM, the job goes into a Pending state basically forever.

Has anyone seen this before ?

So there anywhere to force the Version Installed information on the Machine to update appropriately ?

Thanks for any information shared.

Hi @soneill437,

The job goes in pending state because while provisioning the robot you would have given only username, you have to give Domain\username.

You can get the domain information through command prompt

whoami or set user

Refer the below post.

Thanks, that was it. Problem solved :slight_smile:

But just to reiterate about VirtualBox, as much as I love VirtualBox (I use it A LOT with Vagrant), it seems there is something about the networking side of VB that the UiPath Robot Agent doesn’t like. VMware Player is seems to be rock solid in relation to what the UiPath Robot wants/needs on the networking side.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.