Using CE I have too many licences allocated and can't work out how to unallocate an old one


My laptop HDD drive died and I replaced it. After reinstalling CE UiPath I seem to have too many licenses allocated (I created a new robot in orchestrator as my previous laptop one was effectively dead).

Now I can’t delete my old laptop machine as it says in orchestrator that there are robots attached to it

if I go to robots and try and delete the robot associated with my machine I can’t see anyway to remove the robot.

If I go to License in orchestrator

and if I then go to Manage licence from Automation Cloud

and click on RPA developer - Named User

It says I am using more than allowed please reallocate the licenses (but I don’t know how)

I’m really stuck with this and don’t know how to get back to the point where I can successfully use UiPath.

Any help would be appreciated thanks,


Go to Manage accesses in tenant tab
There you’ll see users created, that are the users consuming licenses, if you don’t want them, just delete them from there and that eill free up your licenses

Hope this helps!

Hi @charliefik,

Please go the respective folders wherein you have your old machine assigned.

Please unassign it from everywhere.

This would automatically delete references under robots section and then you would be able to delete that machine from machines section.


Hi Rahul,

Thanks for the advice but when I go to Manage Access and attempt to remove the Robot (in this case BlackRobot) the remove is greyed out. So I can’t do anything to it.

Any suggestions?


That disable option is because of the access, the current user by which you logged in, is that a administrator? you can check your logged in user roles and give all the administrator access and proceed

Hi Sonali,

I went into my default folder and removed the BlackRobot

Then went back to tenant->Machines and deleted the BlackRobot there

Now it seems like I only have 1 robot (SilverRobot)

but in the Home Licence allocation section it still says I am still using more licenses than allowed when I hover over the exclamation point for RPA developer.

Any ideas please?

Will give it a go thanks

Hi Rahul,

Everything was already Admin. The Black robot is no longer in the list of items in Manage Access (after following Sonali’s suggestion of going to tenant ->robots and removing it from there. I also removed the laptop from machines.

However I still have a licence issue (see previous email to Sonali)

Just to let you know I removed all the robots and then in admin->tenants I clicked on the Edit license allocation icon to adjust the licences which were wrong

Which I think was a step in the right direction as I’m no longer getting the thing that says I have too many robots for the number of licences

Now I think I’ll have to recreate the robots and link them up fingers crossed

HI @charliefik,

Glad that deleting all robots and adjusting license allocation resolved your issues :slight_smile:

You should be able to succesfully allocate licenses to the required machines now :slight_smile:


Thanks very much. I can now open UiPath (I thought I’d never be able to play with Studio on my Laptop again!)

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.