User Interface Automation with StudioX - Generate a Strong Password

i did not have to stop the recording. i hovered over the notepad and used the drop down menu to select click and it opened up the notepad. then i clicked on the screen of the notepad and then pushed the ctrl+v buttons and it pasted. saved the recording and ran the bot.

1 Like

The recorder did not show a change application button as shown in the training.

My version of UIPath StudioX (2021.4.4) does not have the Change Application icon. So I just paused the recording, selected the Notepad application manually, and resumed recording. It was successful.

A great exercise to get familiar with the App/Web Recorder function! I also added a Ctrl+S keyboard shortcut for some extra practice.

This practice project was a little confusing - I did not see the option to change application so like others it seemed the only way to do this was to pause and find notepad and then continue with the recording.

This is fun stuff. Love being able to create! Going to test using 3 applications this week and see how things go.

I had the same issue as you mention in #2: everything else worked except my recording does not capture what the clipboard has after clicking on ‘copy to clipboard’. I also ran the solution and it works perfectly in the solution. I have examined everything between the two versions (solution and mine) that I can think of, to spot a difference, but I have not solved the problem yet. I think it must be something I’m doing when I make the recording…?

All, I was able to solve this after I took a later class, on identifying an image on the screen. When I used the feature that allows you to use the selector to draw around the square image of the ‘copy to clipboard’ button, it worked.

I had the issue #2 and I solve it using the “Double click” activity. Try and tell me if it works for you. I don`t know why the “Click” activity didn’t work for me but worked when I ran the project attached to the practice course.

I did not have the option to change applications from the App/Web Recorder as it shows in the training material. My only options were Record and Save.

image

I didn’t have the switch option and don’t know how to turn it on if I need to

Same here, not straight forward

Thanks for this, super helpful! I already had notepad open but the screen still wouldn’t switch after clicking the “change application” button, alt-tab worked perfectly!

I didn’t get the change application button in the recorder app. But Alt Tab worked for an already open notepad.

IT took a few tries but i got it :slight_smile:

It seems this section could be a little clearer.

I was able to create the recording and run it on the second instance. However I ended up saving the file and on the second instance it wouldn’t save because the file already existed so, I added an “save as” object to the bot to save and overwrite the file name. Cool… Now I need to learn how to append to that file and I’ll be set.