User Interface Automation with StudioX - Generate a Strong Password

You discovered that User Interfaces can be automated either by adding the activities one by one or by recording your actions and having the activities generated. What applications/websites used in your work do you plan on automating?

For any technical question , please create a new topic in the StudioX category here .

The notepad bit was very confusing. Kept trying to click the start bar, type in “notepad,” and then click the icon, but that’s where I’d get stuck. Downloaded the cheat sheet and turns out you’re supposed to direct the recording directly to the path of the program somehow. Not sure how this can be done during recording and not manually.

as a hint, looks like you need to pause the recording, open up the app, and then resume recording so it’s ready for you.

1 Like

I’m not able to unclick the Symbols box after selecting the web page in Recorder. Any one else with this issue?

Use ESC tab so that you can perform that action

I had to stop and start the recorder a few times but finally got it to work.

password length was always 24 even though 12 is what is inserted.

Recheck , you must have missed something…for me its working fine…

I clicked the change application in recorder instead of pausing the recorder, I went to start window- made it as target by clicking there- inert type in from the popup- typed Notepad-and pressed enter- new notepad window will open-go to the notepad, select it and use ctrl +v-done

1 Like

For information, there is a problem in the solution, it does not uncheck the box, but check and uncheck, an option allows to say that we want the box unchecked :wink:

Hi everybody, Would you mind telling me where you found the Password Generator page. I looked but could not see it. Thank you

Hi again, I just saw the password generator. I work on a very small screen and had not seen it below the instructions.

Wonderful! Worked perfect the first time.

You mean this page?

The RPA samples web is quite helpful for testing your RPA workflow.

I could not figure out how to use the recorder to open Notepad. I had to stop recording, Open Notepad and then Use Application /Browser Resource

You could also record in two sequences, first one o the web browser (put the password in clipboard), second recording sequence, (after you open up the notepad) selecting the notepad and input the password by typing ctrl+v.

It worked. After stop recording had to change the “Check/Uncheck fields” because it remained “toggle”

Had an issue with the Keyboard Shortcut at first, but realized it was me. It worked as it should.

Hi John, Please try the following

  1. Add one more activity to change the password length to 12 from 24.

If you are still facing issues, please check the type into activity. It must have the password hardcoded into it. Try replacing it with the value from “paste from clipboard”.

Try the above steps and please let me know in case if you are facing issues again.


I seem to have issues with the recording of the screens: I select the ‘App/Web Recorder button’ (I also have the UI Path extension installed on Google Chrome) and select the correct screen, but it doesn’t do anything. If I then stop the recording, the screen of the browser freezes and the screen of UI path freezes as well. Does anybody know how to avoid/solve this issue?