Used Application/Browser activity studio modern view to login to the portal - The workflow has validation errors. Need solution

Has any one experienced issues with using “Test Activity” in the newest version of Studio? When I try to test a specific activity, I get a warning that I need to resolve validation errors. When I Validate Project, no errors are shown. I can run in debug without the message, but I can’t get the test activity to work.



Hi @jdahlinger

Does this also happen on the fresh empty project? Any chance you could share the problematic project with me via a private message?

Could you tell us if this error you have happens only for this one mentioned activity or for all?
As @loginerror it would be very helpful if you could send (on private) you project to me or @loginerror so we could check it from our end.

A simple screenshot of the entire IF activity that you are trying to test would already be helpful as well :slight_smile:

@loginerror @Pablito I have found that this is only happening with this one project. However, it happens whenever I try to test any activity within the project. I run the debug without issue, but the Test Activity still isn’t working. This is the first time I am using Invoke Workflow and passing arguments, so I am wondering if that is the issue, but I can’t identify what the exact problem is.

Would you mind sending the zip of that project by a Private Message here on Forum? If it will reproduce the issue on our end, I’ll attach it to the internal ticket and we’ll get it fixed :slight_smile:

Hi. Has this been solved? I have same issue while testing an activity. It is a simple type into, I have filled the variable in locals and should not require anything else, right?

Hi @GibPad

Welcome to our UiPath Forum! :slight_smile:

This issue is currently being investigated. It will be fixed in the future releases. As an unfortunate workaround, it seems that it typically only affects specific project and should not happen on a new project.

Could you give it a try?

1 Like

Hi @jdahlinger

I believe this issue has now been fixed in Studio 20.10.5

1 Like

Hello, not really, this happens frequently on my projects, I am running Studio 2021.10.8

Hi @mbataineh

Would you mind sharing more details? (for example, a zip of a sample project)

Please also make sure to update the activity packages to their latest versions.

This issue is occurring when you are using the new studio in modern view and earlier the project was worked in classic view and you have classic activities in project. Just toggle the switch in setting ,remove the project and relaunch it

Thank you for this solution. I had the same issue with the project I was working on.

This solution is not working , tried it and still got the errors, I’m building a library project, maybe it’s a different issue in UiPath ?

I had the same issue. For me the solution was to delete all maually filled variables before testing an activity where these variables are not used.