UseApplication opens the application but then shows Timeout Error

Hi guys,

I’ve just started a new process. That basically opens a windows application (I think written in python) in our company called “bee4it”. It’s just a .exe file.
Then do some standard click activity in it.

The problem is, the selector is valid (100 % score). The application open’s but then after the 30 seconds I get an error: Timeout reached

Not even a Log Message right after starting is shown, so all activities inside use Application don’t run. So i can’t even check for a Check App State since it doesn’t run.

The app is clearly visible to me and when I stop the process and then click on “indicate on screen” it shows me the app so it does see it.

The timeout for use Application is set to default 30 seconds. The app when the process starts opens in about 3 seconds.

I really don’t know how to move forward from here.

Anybody has an idea?

PS: I also tried the exact same with classic experience instead of modern ==> Same problem

Hi @GeraltDieSocke

You are telling it’s throwing an error when you open the app right?

Have you tried start process or open application instead of use application activity


Hi thx for your reply.
Yes Open Application is the same problem.

Yes exactly. Here is the error message:


This appears after the application has opened and about 30 seconds pass (timeout from use application activity). But the application opens and is clearly visible to me.

Have you tried with start process activity?

Hi, that works indeed. But why does that work and not with use Application? I’m kinda confused. Thank you very much.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.