Use shortcut to start application

Hi all,
I have a problem to start an application with the robot. When I use the shortcut on the desktop the application start so that is ok.
But when I want to start it with the shortcut in the directory (by using start application or start process) it is not working. Also recording with double click does not work.
Who can help me with this issue

Michel Rusman

@mrusman - any error while using start process/start application?
are you providing complete path of the application as input ? or giving the application shortcut path?

1 Like

hi @mrusman,

  1. Right Click on the shortcut and click on Open File Location.

  2. Go to the Folder , On the Exe , Press Shift and Right Click - You will get an Option - Copy as Path

Use the same in Uipath to Open the application


Mukesh

Hi @mrusman

Start Process Will work but you have to select that marked one and indicate the application

image

Or if your using any Click activity for clicking In property panel —>change click type as click-DOUBLE

thats it
Regards,
Gulshiyaa

Hello Mukesh, I have tried your solution but then I got the error that it cannot find the .exe file

I had the same issue: App started correctly when double clicking it’s .exe manually but failed to start when using Start Process or Open Application activities.

Found that completing the “WorkingDirectory” attribute with the root folder would solve this problem.

i.e:
Filename: “C\AppFolder\app.exe”
WorkingDirectory: “C\AppFolder”.

Don’t know why but this worked for me.