Use of row function in Cassandra Select

Hi,
I need little help with use of row function from for each row activity with cassandra select please. I got the below error when I use the row function in Cassandra Select activity.
How do I avoid this error?

Source: Select
Message: Invalid string constant (1234) for “xyz” of type bigint
Exception: System exception

Below is a select I got an error “Unknown function row called” for row function. I used select like this in Cassandra select activity.
“select a,b,c
from d
where e =row(0)”

Apology, I don’t know Casandra. The error message indicates the row() function does not exist - which would be true unless you created a custom user row() function within the scope of your application.

I assume that the “select a,b,c from d” works without a WHERE clause, correct?

Normally a WHERE clause would identify (as you wrote it) a column “e” in table “d” and then it is compared to the value on the right side of the =.

Does “select a,b,c,e from d” work? I would hope so because the failure message indicates the row function being the failure.

Therefore what is the value of “e” that you are trying to retrieve? Maybe: where e = “Happiness” hopefully.

Given that row(0) implies you are trying to get the first row, then in Cassandra instead of the WHERE clause use the LIMIT clause as in “select a,b,c from d PER PARTITION LIMIT 1”.

Also note: for performance on large data tables, also make sure you indexed the column “e”.

Hi, Thank you for your help with this.
a) Sorry I should have provided mode details.
I used for each activity.
Then used then tried to use the row(“column name”) or row(0) in the cassandra select.
b) I did not try the select with out “WHERE” clause.
c) You are right I was doing the query little wrong in the select statement. I updated my select to correct format like below and it worked.
"select a,b,c from d where xyz = " + e + “”
“e” assigned variable obtained from a excell using for each and the row function.