Use Browser is missing settings like “Private” & “NewSession” in the Modern Design

Your project seems to work for me :sweat_smile:
I went ahead and did a text compare between the both project files, and one thing I found is that you do have some corrupted namespaces in your project:

Which brings a question - does this work on a new project?

  1. Create new project
  2. Add image activity
  3. Use image to indicate Chrome window
  4. Fill in the properties:
    image
    image

These are the steps I did.

Ok here the steps I did:

  • Start Studio 2020.10.4. Enterprise
  • Create New Project
  • Add User Browser and link to Chrome
    • grafik
    • grafik
  • Set parameters
    • grafik

Still Chrome opening in non-incognito.

I dunno what I am doing different. But as your example works for me, it just can be something with the Object Repository that might be different.

Could you share yours?

2 Likes

Thanks, I registered the bug and I will keep this topic up to date. It is indeed the Object Repository, it overwrites the custom properties while not allowing one to edit them within the Object Repository descriptor.

Easiest way to reproduce it is to add a new Use Application/Browser activity, modify the properties (such as the argument “–incognito”), and then drag and drop the Object Repository descriptor on top of it. It will reset the argument to the default blank.

2 Likes

Can you already say how long this will need?

Our team had a look and the improvement is currently being tracked where you can edit the arguments of the screen in all cases (currently you can only do that for applications that aren’t a web browser)

In the meantime, the workaround would be to first prepare the activity and then add it to Object Repository:

It will then retain the extra arguments that were set.

Thats not possible. You can set the target Argument when it is not connected to Object Repository. How you did that?

Can you give a step-by-step maybe?

Or when will the fix be available?

Indeed, the only workaround for now is to:

  • add Use Application/Browser that is not linked to Object Repository
  • fill in the arguments (such as “–incognito”)
  • then add your activity to Object Repository as a new screen and it will remember that argument

As far as the timeline, I cannot share any specifics just yet.

Does not work. Should I create a screencast of this so that you believe me I’m doing it correctly?

Just did it exactly as you said. Very sad that it’s so buggy.

I got this problem also, my workaround was to use the classic version ‘Open Browser’ activity, and then use the ‘Use application/Browser’ activity from the new version to attach to the opened browser.

What an interesting hack but that does not sound good as you finally have to cleanup this when the bug has been fixed. Right?

Not necessary if you think about it. Its not like Im putting too much hacking or something that is not on Out of the box from the solution.
But yes, it would still be something that could receive some cleaning.

1 Like

It’s really not necessary to do any such hacks (using Open Browser)

Add a new Use Application/Browser, configure it to your liking (make sure it works as expected) and then add it to OR.

What does this mean in detail? As I said, I already tested it and it does not work for me. What is OR?

Super strange. For the record, OR in this context means Object Repository.

Let’s try with a sample project with a working Object Repository screen for Chrome:
BlankProcess34.zip (11.0 KB)

Could you give it a test like so to see if it will add the object correctly:

1 Like

Your example works.

But then I tried again in your project to create another application in the OR and the Chrome screen. And again the “–incognito” is always gone.

So the question is how did you add the parameter on the screen? There is no property window of the screen and the selector is identical to yours.

And cant see any difference so maybe you also show how you added app and screen and where that incognito comes from.

And for sure I selected incognito Chrome.

Sure, see here:

Alright, that solved it.

Well that’s a hack because after selecting the application it wants the screen directly. And here you need to click Cancel. That is the tricky hack. But that works. Just set the setting and then at the end link to the new screen.

Thanks for the help. But that means, when I would like to change settings after I linked the screen, these changes are not applied? Or is it only Arguments that is ignored?

All settings that are under “Unified Application target” are linked to OR.
Any changes that you do are ignored and OR object settings win.

Interesting but absolutely confusing. So maybe give the possibility to change those settings on the OR object would solve any issue and everyone is happy.

WDYT?

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.