Use Browser is missing settings like “Private” & “NewSession” in the Modern Design

For me that’s a huge step back. The new Use Browser is missing settings like Private & NewSession in the Modern Design. So it’s not possible to open Chrome in private mode anymore. So currently the only workaround is to hit CTRL+SHIFT+N as Chrome shortcut:

enter image description here

But for me that does not sound like a good solution as browsers can swap that hotkey or having different.

So before without the Modern Design is was possible to set incognito mode in Open Browser:

enter image description here

So why is that feature gone in the Modern Design rework? How to get it back without the workaround and still using the Modern Design?

Hi @kwoxer

I believe this is how you would currently achieve it for Chrome:
image

But fair point that the new experience could probably use some fine-tuning. I’ll record this feedback so that it doesn’t get lost :slight_smile:

1 Like

Ok thanks this works. But this is just another way to open Chrome and start another Chrome incognito. Not a real solution on this.

But I would like to open just exactly one browser window. So how do I now programmatically make sure these both browsers are closed at the end. Usually I just save the browser instance of the browser. But now I would need to save 2 instances to close them at the end? I know I could also just search for opened Chromes at the very end. But maybe there are more then these 2 Chromes opened, that would mean misbehaviors.

So please let me know when this is more practicable.

Could you please share your workflow sample that opens two windows? The method posted above opens exactly one browser window in incognito:

I want to make sure there is not actual bug here :slight_smile:

Sorry I tested it incorrectly previously.

Actually your solution does not works for me. I have the identical setup and parameters and it just opens the Chrome in the regular mode.

So browser is not incognito.

1 Like

Interesting. One quick check, the package version. I tested on the latest:
image

Could you confirm you get the wrong behaviour on this version?

This one is the latest that I can choose. Could you maybe test with my version?

And maybe test a version that is not a prerelease?

with "studioVersion": "19.12.0.61" in project.json

and grafik

I checked and works for me with that version of UIAutomation. I asked our team and it looks like the Chrome version might still be a factor.

Could you let me know what is your Chrome version and the version of the UiPath Chrome extension you have installed?

I have Chrome Version 88.0.4324.150 (Official Build) (64-bit).

And tested again, still no incognito mode.

1 Like

Same as my version. Let’s find out what is happening. I recall there is also this option, could you check if you have it active in your UiPath Chrome extension settings?
image

sure as that setting is a must have :slight_smile:

Can you maybe upload your xaml file?

Absolutely, could you try?
TestingChromeIncognito.zip (3.4 KB)

1 Like

No idea, your example works perfectly. So I compared to mine. I cannot see any difference at all. Here is my BlankProcess. Maybe you can tell me the steps you did. I think it is something with the Scope or the Object library.

BlankProcess.7z (4.0 KB)

Your project seems to work for me :sweat_smile:
I went ahead and did a text compare between the both project files, and one thing I found is that you do have some corrupted namespaces in your project:

Which brings a question - does this work on a new project?

  1. Create new project
  2. Add image activity
  3. Use image to indicate Chrome window
  4. Fill in the properties:
    image
    image

These are the steps I did.

Ok here the steps I did:

  • Start Studio 2020.10.4. Enterprise
  • Create New Project
  • Add User Browser and link to Chrome
    • grafik
    • grafik
  • Set parameters
    • grafik

Still Chrome opening in non-incognito.

I dunno what I am doing different. But as your example works for me, it just can be something with the Object Repository that might be different.

Could you share yours?

2 Likes

Thanks, I registered the bug and I will keep this topic up to date. It is indeed the Object Repository, it overwrites the custom properties while not allowing one to edit them within the Object Repository descriptor.

Easiest way to reproduce it is to add a new Use Application/Browser activity, modify the properties (such as the argument “–incognito”), and then drag and drop the Object Repository descriptor on top of it. It will reset the argument to the default blank.

2 Likes

Can you already say how long this will need?

Our team had a look and the improvement is currently being tracked where you can edit the arguments of the screen in all cases (currently you can only do that for applications that aren’t a web browser)

In the meantime, the workaround would be to first prepare the activity and then add it to Object Repository:

It will then retain the extra arguments that were set.

Thats not possible. You can set the target Argument when it is not connected to Object Repository. How you did that?

Can you give a step-by-step maybe?

Or when will the fix be available?

Indeed, the only workaround for now is to:

  • add Use Application/Browser that is not linked to Object Repository
  • fill in the arguments (such as “–incognito”)
  • then add your activity to Object Repository as a new screen and it will remember that argument

As far as the timeline, I cannot share any specifics just yet.