Use application/browser

I am learning UI path and going through UI path trainings from UiPath Academy. i am facing issue when building my first application using UI path SutdioX. i am using “Use application/browser” to identify an element from chrome but when i click on indicate application StudioX gets terminated automatically. I even tried using IE but facing the same issue.

UiPath StudioX version: 2020.4.3

Hi @Pradeep_Kumar_Sahoo
Welcome to the UiPath community. This is not a common problem, so it may be just your installation or some configuration issue.
Before completely uninstalling the software, I would suggest switching to stable versions of activities packages.
You can do this by going to Manage Packages window from your toolbar:

Change any ‘beta’ versions to latest stable ones and try again.

Thank you for replying to this post.

I have tried to update all the dependencies to latest stable version. Also tried uninstalling StudioX and re installing the stable version still facing the same issue.

by any chance can you upgrade to 20.10 version?
if not, from package manager, can you update the UIAutomation package? which version do you have right now?
For Chrome did you first installed the Chrome extension? it’s in Home-> Tools section of StudioX. Make sure is properly installed and try again please

1 Like

UI Path StrudiX Version: 2020.4.3
image

event tis not working for IE as well.

Can you please guide how to upgraded to 20.10

You can always download the latest UiPath edition from Automation Cloud - Resource Center

Also, check application logs to see if there’s something else on your computer or firewall settings that are blocking the software.

can you uninstall the automation.next package and then try again?

1 Like

Still no luck.

Updated UI path studio to 20.10
StudioX 2020.10.0-beta.1008 - 10/5/2020
Community License
EXE Installer

License Provider: Internal
Activation ID: UIP-19e1617792

Update Channel: Stable

Microsoft Windows 10 Home 64-bit
.NET Framework Version 4.8


if you are trying to indicate for example another application instead of the browser, like windows explorer, a folder, notepad, do you get the same behavior?

Yes, As soon as i click on indicate application, The studio is getting terminated.

can you please attach all logs? ctrl+L in studio to get to the logs location and zip all of them

PFA the logs2020-10-13_OfficeExtensions.zip (29.2 KB)

Please create a crash dump and send it by following these steps:

  • Download the ProcDump utility
  • Extract it somewhere on your HDD (for example c:\ProcDump, but you can put it anywhere as long as you remember the location).
  • Open an Administrator CMD in the ProcDump directory and type:
    procdump -ma -i c:\dumps
  • Create a directory C:\dumps and grant full access to Everyone for it from the Windows Security properties of the directory.
  • Reproduce the crash.
  • You should find a file named like C:\dumps\UiStudio_[...].dmp. Archive it using ZIP and attach it, please do not send it unarchived. The file might be too large to attach to a thread post, you can use file sharing like OneDrive or Google Drive.
1 Like

I have generated the crush dump as per the above steps. Below is the link

1 Like

Thanks for the crash dump, it was very helpful. You can disable the generation of crash dumps by running "procdump -u" from an Administrator CMD console. If you leave it enabled, it may fill your disk with crash dumps of every crashing program on the system.

I would also need a log from our low level Driver component. Please perform the following steps:

  • Open cmd.exe as Administrator
  • Navigate to the path where UiPath Studio is installed (usually C:\Program Files (x86)\UiPath\Studio) and run
    UiRobot.exe --enableLowLevel
  • Reproduce the bug
  • Run this in the same CMD Administrator console to disable the logging:
    UiRobot.exe --disableLowLevel
  • It will generate a file on desktop with an ETL extension, please archive it and send it to us.

PFA the file you requested
UiPathTrace-lpvngnnx.zip (1.6 KB)

Our analysis has revealed two problems:

  1. A certain Windows API that we are using is failing. This API is necessary for the visual selection. The reason for failure is very generic and so far we could not pinpoint a specific cause for it. The official Microsoft documentation does not say anything useful about it. Possible reasons are:
  • An antivirus or anti-spyware which is restricting apps from calling certain Win32 API-s.
  • The user has restricted rights. Can you try with an Administrator account, just for checking?
  • A slow system for various reasons: either there is another problem loading the processor, or there is very little RAM available. Is the system a physical or a virtual machine?
  1. The failing Windows API indirectly produces a crash in our Driver component. This is a bug on our side and it has been fixed. However, this does not fix the failure of the Windows API, so the visual selection will still not work on your system due to the strange software configuration.

Can you please try to Indicate an element using the visual selection from UiExplorer? If the selection works, do the special hotkeys work during the selection process? For example, does pressing F2 delay selection, or does pressing Escape stop the visual selection procedure?