URL retreives # symbol


#1

Hi,

I have a webpage contains 10 links which have the same name called ‘Details’. I have to click on each ‘Details’ to retrieve the info and then to click GO BACK button to return to the webpage. Also, In a webpage, I can retrieve only 10 Details, but I have several pages. In each page, I have to perform the same.

Note: I tried with data scrapping, but the URL for ‘Details’ retrieves # symbol. I also tried with '‘Get attribute’ activity, but it retrieves the same URL for all the ‘Details’.

Kindly someone help me on this, as I am working on a project to prove Uipath automation can make big changes to the industry am working on.


#2

Did you try href instead of URL?


#3

No… I don’t have an idea about that. Can u help me on that.


#4

if you pass href instead of URL in get attribute,what is the result?


#5

it returns # symbol


#6

Do you see the URL you are expecting in any of the properties of UiExplorer?

image


#7

image


#8
  1. When you click on that link what happens? You are redirected to a different page or scrolled down on same page or a pop up appears?
  2. What happens when you right click on link and do select shortcut or copy link? what url do you get?

#9
  1. It is redirected to next page.
  2. When I copy link, it appears like "https://www.abcdef.com/ProviderPortal/claims/CheckClaimStatusResult.do#

#10

Also, When I try to view the page source, I found that it is a javascript program. Please see below for the code snippet for the ‘Details link’
< a href=’#’ onclick = detailslink();>

Hope this info will help you to find a solution for my problem.


#11

Yes, it is calling a js func on click event.

Probably you can do Find Children and click on all elements without with aaname= Claim and do your logic and come back to main page (Navigate url).

or (not sure it works) use this in foreach

Children.Where(Function(x As UiElement) x.Selector.ToString.Contains(“aaname=‘Claims’”))


#12

thank you for your prompt response… I am tryiing on it. I will update you the status


#13

Not working for me. :cry:.


#14

Its working fine now. But the problem is, it is always performing the action on the first element. Can you please help me.


#15

Can someone find me a solution for this?


#16

I noticed you have a tableRow attribute. What you could do is use a loop and increment rowNumber by 1 each time you click the element.

You can then edit the selector to use the variable. You need to edit it as a string by clicking inside the Selector text box in the Parameters for the activity.

"< ......     tableRow='2' />"
to "< ..... tableRow='"+rowNumber.ToString+"' />"

So, when you have rowNumber=rowNumber+1, it will add 1 to the row number and click each link until there is an error and the element doesn’t exist.

EDIT: How that collaborates with vvaidya’s ideas, I am not sure. You might be able to instead run a ForEach loop with the Children.Where( ) method if it returns a list of links you can click and ignore my previous idea.

Regards


#17

Thank you… I did it using find relative element activity.