[URGENT] Robots run in unattended environment once and then lose focus

I have an environment with unattended licenses, the Orchestrator is connected to a virtual machine and the robots are executed in the virtual machine.
I have a robot that as a first step is to log in to a web page (bank page). These are programmed in the triggers to be executed at different times, however I have these results without entering the machine (since it is an unattended execution).

  • First execution, it finishes correctly.
  • second run, completes successfully.
  • third run, ends with login error, with the detail that the robot could not find the first field in the login page.
  • fourth run, same problem as third run.
  • 5th run, same problem as 3rd and 4th run.

As detailed above, the runs start fine and then fail on subsequent runs. Additionally, in one of my tests and validated that when I enter the VM when the robot would already have the login page, it loses focus and when I click on the screen, it continues; Otherwise, if I don’t click on the screen, it fails with the same result as the executions with errors detailed above.

Finally, these errors are intermittent, some days they happen and other days they all happen fine.

Please your support to find the error.

Hi Jean,

Have you tried using the “Wait for ready” property using UiActivities?

WaitForReady – wait for the target to become ready, before performing the activity. There are three available options:

  • None – does not wait for the target to be ready.
  • Interactive – waits until only a part of the app is loaded.
  • Complete – waits for the entire app to be loaded.
1 Like


there are some missing Information:

  • Full error message
  • Which operation system is used for the unattended robot vm.

Also make sure that the robot user is logged out (not only disconnected) from the machine.

Maybe you are affected of the following issue:

Hello @carlosevp ,
I have updated two of my four bots that have this intermittent execution (sometimes it works and sometimes it doesn’t) and the result is that these two updated bots now work correctly on all their scheduled triggers.
So far, this is the solution that helped the robots work successfully. However, I do not want to close this topic until they work successfully for at least three days, since previously, it happened to me that they work well one day and the following ones start to fail. Thank you very much for the information @carlosevp .

Likewise, remind the forum that the problem was in the bank website login. Of the unattended scheduled triggers, at least two out of eight bank executions worked (I have four robots for four bank pages and each one with at least eight robot triggers), the problem being that the robot did not find a start field session to be able to execute the type into activity. Here the detail of the error:
“Exception: Timeout reached”

1 Like

Thanks for updating the topic with your experience and sharing the results. Take care @Jean_Piere_Ochoa!

1 Like

Thanks a lot. This worked for me. The robots since then have run without any problems. For the forum, I have used the Complete option of the WaitForReady.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.