[URGENT] Passing over string doesn't work in some cases


#1

Hi,

Found some weird issue, Would be glad if someone resolves it.
I have a scenario where i need to pass the variables in a web pop up. like start date, start time, end date and end time kind off… for eg., “01/10/2019”, “12.01AM” , “01/19/2019” , “12.15 AM”.

I wrote a separate xaml to test this by hardcoding the values which i mentioned above and it works fine (which means, it identifies the selector and gets completed). but, when i imported the same sequence in to the main flow by passing the arguments instead of hardcoding - it fills the first value and not passing on to the second.

I had a mild doubt that passing the argument cause this issue kind off… so i passed the time value as a string/Generic value in the separate xaml (which was working earlier) and that too didnt work. Am i doing any mistake here? any other solution to this? pls help as soon as possible.

image
image


#2

Hi @kk.virags

Just curious on a few things:

  1. When you tested the hardcoded values, were they string or a generic datatype? Did you use the same when the you passed the values in?

  2. Any unnecessary white spaces you needed to trim in the argument?

  3. You mentioned the selector works in the .xaml, but were there any changes in the website/title in the main workflow that may cause the selector to be wrong?

  4. Just a wild attempt to rescue this - try to include a short “Delay” Activity between the 2 Anchor Base activities. Maybe 1 or 2 seconds.


#3

Hi Nisa,

Thanks for your response and time on this. please find my response below.

1.yes, both the values are string.
2. have used .trim to remove the white spaces.
3. had used highlight to see whether the selector is pointed in correct way, it is actually finding the selector but not able to pass the values.
4. yea, i did that as well… it didnt work out.

Trying to investigate further. I believe it should be some silly issue, but since its the very big workflow just wanted to take a chance if there is any other solution to process the data for dropdowns.

Thanks,
KK


#4

All,

Have solved this issue. Its again a new learning hope this helps to some ppl.
The input format and the hard-coded part (though both are string) the time part is in the “hh:mm tt” when i send the string in the flow… where hard-coded part is the usual thing everyone does "h:mm tt"

So when i worked separate on this, i gave it like “3:23 PM” and it worked. but, when it comes to the workflow the application is not accepting it as its designed to have entered as “3:23 PM” where the string is passed as “03:23 PM”.

We might leave out this formatting issues and would concentrate on the String/Generic/Integer or conversion or selectors. Its a silly mistake which we could never guess… ** A little learning of making code perfection**

Thanks,
KK


#5

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.