Urgent help with the REF, does not pass INIT

good afternoon, I have a big problem
well I already finished the advanced developer training and good nose because this happens to me
the problem is that I want to use the REF for the next job, read an excel file already located in the Data folder and then extract a certain value and with that value generate a code that I will then write it in the same excel that was read

and tried to modify the variables of the REF to poçrobar with which it works but nothing turned out to me

In INIT, place a workflow invoke to open a certain browser tab and read my excel file that, by means of arguments, connect it to the variable, since my biggest problem that it does not pass from init is that I get it in the output there are no more transactions and it closes

the thing is that I want to get to process since I will not use “unless it is indispensable”, and there I have my workflow that also connects it to the transaction data variable, but as I said at the beginning, it does not happen INIT and I don’t know why

could someone help me is urgent

Hi @borismh,

Could you show what you have created inside Init so that we could validate what went wrong ?



Of course I share them now

ROBOT VILLA ANDINA-boris.zip (2.2 MB)

Ok I think I understood where the problem is, you are initiating everything in Init and reading data from Excels in your xaml name - Leer_infor_de_entrada, but not adding it to Orchestrator.

In Get Transaction data your process is checking for stop signal and then entering GetTransactionData.xaml where:

  1. Get Transaction Item is disabled.
  2. There is no data added to queue prior.

Thus, since out_TransactionItem is Nothing it is exiting the xaml and entered End Process.

I hope this helps and if it does, please take rest. :smiley:

This happens when you invest too much time in building a solution. :stuck_out_tongue:



Ok, so what do I do?

If you want to use Orchestrator then add these Datatables in Orchestrator using Bulk add queue items activity or add queue items activity. You can either build this in Leer_infor_de_entrada or create a new xaml below invoke Leer_infor_de_entrada workflow as you are already passing these datatable using out Arguments.

This way, once data is added to the Orchestrator, you can use get transaction item in Get Transaction Data state to fetch these information.

else, if you want to use these Datatable directly, pass them in Get Transaction Data State and perform the required operation, which I think you have done in Process State.

1 Like


I don’t want to use the orchestrator
but in what way do I connect the tables I read, because if I connect it to transaction data, it still throws me out that there are no transactions, and if I connect it in transaction item, I still throw the same result

help, what steps do I have to follow to identify my entire table as a single transaction

Hi @borismh,

In your transitions, NoData and New Transaction, you have to change the conditions. For example, in order to move to Process transaction, you are checking if TransactionItem is Nothing, instead export your Datatable in the form of arguments and then as variable and check in New Transaction transition if these data table are not empty. This way it will allow you to move to Process transaction where you will perform your actual operation.

I hope this clarifies.

1 Like


Hi excuse me if you can teach me by steps, do you have time?

Hi @borismh,

Its not practically possible as we are discussing this in Forum, however I could guide you when you get stuck somewhere. I hope you understand. :slight_smile:

I am asking you to put Leer infor de entrada.xaml in GetTransactionData.xaml and assign the variable to the out arguments. These variable should have bigger scope to your main flow so that you could pass them in process.xaml as well to process them in rest of the xaml you have kept in Process.xaml.


1 Like


I plan to work with only one transaction and I don’t want to use “add queue items” because I find it more difficult, I have to change the transaction item variable since it is “queue item”
please excuse me


and managed to get to process, but now it does not leave there it stays in an infinite loop
damn it doesn’t come out