Urgent : Downgrade version from V2020 to V2019

I developed a code using the community edition Version 2020 of UiPath then I tried to downgrade it so that it is compatible within uipath version 2019 ,
It’s done for now but I can’t see the photos of buttons as shown in this pic
What can I do to get them back ?

@Wafa_KACEM
not all steps done by you are mentioned. Focus on the content of the screenshot folders from the projects. Once you copy between projects then it will be picked up again

1 Like

@Wafa_KACEM

It not a issue with Version, while copying any project, you have copy all the dependencies associated with it, then you can open that

as ppr suggested, you need to copy .screenshots folder to get the screenshot

Hope this helps

Thanks

And for dynamic selector , what I have to change when going from 2020 to Uipath V2019 ?
I have this dynamic selector , it s no longer valid in Uipath V2019

{{VarName}} approach should be valid. Can you tell us the versionof referenced UiPath.UIAutomation.Activities And UiPath.System.Activities?

also check the variable definition and if it has valid Default Value mathing the presented and to test selector

Version of UiAutomation.activities , I think i ve a problem in here



Ps : Now i m working on studio V19.4.4

If I modify UiPath.UiAautomation .activities fron V20.4.2 to V19. 4 , i get this errror

oh, corrections maybe can be done via XAML editing if it is necessary. But is not a nice job. I will revert later to you with some more details.

I can t go further without solving this

I v solved this by writing V20.4 on the JSON file but the method of dynamic selector still not functional in this version although it cabn select the value ! :frowning:

just a few words on the downgrading / manually corrections:

I had the same case with a doWhile started with 2020.4 required to get downgraded to 2019.10 (I am refering to the UiPath.XX.Activities Vesion)

  • create a XAML with the same activity on 2019 level
  • open both XAMLs in Texteditor
  • compare the differences and edit
  • in my case I removed some element name prefixes like id:doWhile - changed to doWhile

and I got it downgraded.

About the dynamic selector at the moment the issue that you are facing is unclear. What is meant with “I cant select the value”? Just recreate the dynamic selector and check variable, default value and present element selector

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.