Upload File to Sharepoint

@ELISA_ARTALEJO_BARINAGA

Welcome to forums

Could you please share more Info on the error like some screenshot of the workflow you are doing

Thanks

H

Welcome to UiPath forum

Have a view on this thread with similar discussions and solutions as well

Cheers @ELISA_ARTALEJO_BARINAGA

1 Like

I would first type the path you are using in a word doc manually and then click it to see if the site opens. It may be that you do not have the full path identified…does your path start with //https: and end with .aspx?

Hi @ELISA_ARTALEJO_BARINAGA Welcome to the Forum !

Did you solve your problem?

Hello, thank you for your reply,

I get the error in the “Find Files and Folders” activity, the url is the link to a Sharepoint folder where there is another folder called “RPA_Test” where I want to save an Excel file.
If more details are needed, I will tell you.
Please find attached a screenshot of the process:

Thank you all for your responses! :slight_smile:

Hi! I have tried what you say about the url link by pasting it into a word and it works perfectly, it starts with https:// and does not end with .aspx.

In reply to another comment I have attached a more detailed picture of the process.

Thanks for your help!

Not yet! I am still trying to fix the error.

Thanks. Can you tell me what version your package is?

I understand you mean the Microsoft Office 365 package:


Thanks to you!

Hi @ELISA_ARTALEJO_BARINAGA

This maybe could help … Upload File to a Document Library in SharePoint

Lets us know.

Hi @carmen,
That is the model I followed and I got the error.
I haven’t put the activity “get item info” because it doesn’t appear, could that be the problem? How do I make it appear? It is not included in the Office 365 package to me.

Thanks.

My URL link is:

The problem could be the signs? or maybe too long?

You are right … I just downloaded to check and also I couldnt find it …

I would also suggest give a try to this other activities … also you can find a pdf with a clear documentation …

Thanks! i have tried but i don’t have credentials for AppOnly or AzureApp.

your site address begins with https:// and ends with .aspx? This is the sharepoint URL. The rest of your URL is an absolute address for the sub-folder. Use just the Sharepoint address in your code and see if you can access Sharepoint that way in your automation

As i said before my url is this one:

It starts with https:// and it doesn’t ends with .aspx. I’ve used just the sharepoint link but it doesn’t work

Hi,

I guess what Chris meant the url to be:
“https//XXXX.sharepoint.com/sites/UKProcurementTeam-Internal”
or
“https//XXXX.sharepoint.com/sites/UKProcurementTeam-Internal/Shared%20Documents/Forms/AllItems.aspx”
(I guess the former one is the correct one.)

How does that work?

Correct - O365 Sharepoint sites end in aspx. This tells me that since you cannot get into the site with just the aspx it means that whatever account your bot is using to attempt entering the sharepoint site is access restricted.

Thank you all! :slight_smile:
Finally changing the url to “https://XXXX.sharepoint.com/sites/UKProcurementTeam-Internal” as @AigoHigurashi advised me and changing the path in “subfolder” and “Drive Name”, I managed to upload it.
If anyone wants more details of the process, please write to me.

I wouldn’t have made it without your help, thanks again.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.