Upgrading Orchestrator from 2016.6232 to 2017.1

orchestrator

#1

Scenario: When updating the Orchestrator from 2016.6232 to 2017.1 using the update script provided by UIPath we are getting the message saying that a blob’s cert located at a certain location is marked as secure. You must specify an encryption password to archive this property. It’s nothing our I.T. department have done and appears to be a problem with the BackUp operation. I can’t give you much more as it will possibly give sensitive data but wondering if anyone had come across anything similar and if they had managed to get around it.

Spoken to UiPath but waiting to hear back from them.

Steps to reproduce:

Current Behavior:

Expected Behavior:

Studio/Robot/Orchestrator Version:

Last stable behavior:
Last stable version:
OS Version:
Others if Relevant: (workflow, logs, .net version, service pack, etc):


#2

Hi DaveO
I got the same issue. Did you get a solution from UIPath?
Br
David


#3

To fix the issue you have to correct manually the Utilities.psm1file.

Add the parameter to -SourceSettings @{encryptPassword=‘BlaBlaBla’} to the line (or lines)

where you call the Backup-WDSite cmdlet (in my case lines: 523 adn 527)

So the line should look like something below:

Backup-WDSite -Site $websiteName -SourceSettings @{encryptPassword=‘BlaBlaBla’} -Output $backupDirectory -Verbose 3> $null

Of course, the password text is up to you :slight_smile: