Updating a transaction priority via API request

Hello there!
I`ve been experiencing a problem with the Orchestrator HTTP request activity. I can successfully use it to make GET requests but when I try to update the priority using this activity and the PUT method this is the JSONresponse I get:

Status Code
404

Response body
{
“message”: " does not exist.",
“errorCode”: 1002,
“resourceIds”: null
}

Same thing happens when trying it on swagger.

I understand the 404 is when the request can find the page or object but I use the same structure and ID on the GET request and it works just fine.

This is the values in my Orchestrator HTTP request activity inputs:

JSONPayload:“{Priority: ‘High’}”
Method:PUT
RelativeEndpoint:“/odata/QueueItems(”+item.Id.ToString+“)”

I’ve tried populating the Folder Path input and without anything on it as well.
I`ve checked the robot I’m logged in permissions on folder>Settings>permissions and they are:
Robot Type: Attended, Unattended
Roles: Robot, Administrator, Tenant Administrator, Allow to be Folder Administrator, Folder Administrator, Allow to be Automation User.

So it seems the robot should have the correct permissions to update the transaction.

I’ve also tried to use the assign activity to change the item priority but it isn’t reflected on the orchestrator queue:

item.Priority = QueueItemPriority.High

Hi.

you have to specify at least the queue name.
image