Update to beta version [issue]

update

#1

Hi All,

Ok - I “old” enough to play with beta version - however I have major issues with updating it.

I’ve checked the beta channell in UiPath, I’ve restarted the UiPath (I even went step further and I’ve applied standard “helpdesk” trick - I’ve restarted my computer :slight_smile: ) but no luck.

I’ve tried playing with folders in “C:\Users%userprofile%\AppData\Local\UiPath” where I saw two folders:

  • app-18.4.0-beta0111
  • app-18.4.0-beta0113

I’ve changed name of those folders by adding “_” at the begining of the folder name. No luck - I thought that when I will launch UiPath new folder will be created and Beta version will be downloaded - but this did not happen.

I’ve digged little bit more and I found “Update.exe” file, so I’ve tried to launch it as per the help information, so:

  • Update.exe --install=app-18.4.0-beta0113
  • Update.exe --install=app-18.4.0-beta0111

I’ve tried it with both folders but no luck - this command did not do anything.

BTW. size of those folders are:

  • app-18.4.0-beta0111 -> 172 MB (181,243,904 bytes)
  • app-18.4.0-beta0113 -> 172 MB (181,256,192 bytes)

Attached are two screenshots - from UiPath / folder structures and from command line.

command_line

If this post is duplicated - and case has been already solved then sorry for that and please let me know where to go.

If not then - two questions: Is it a BUG? Is there any workaround to get BETA version?

If any more information is needed, please let me know.

//BR Marek!


#2

Hi @Marek_Malinowski

Interesting. Could you switch to the Stable channel? The 2018.4 CE is released as per our banner.

I think your issue is simply due to the fact that there is currently no running Beta :slight_smile: (which is weird, because one would think that you would still get upgraded to Stable release :slight_smile: )

We will investigate.


#3

Hi @loginerror

Thanks for answer!

I’ve tried it but no luck - the same is on stable channel. Same steps reproduced - changing channels is not triggering a download (if I’m properly assuming - new version should be downloaded to: C:\Users%userprofile%\AppData\Local\UiPath), restart is not helping.

So I’m still “stuck” with 2018.3.2.

//BR Marek


#4

Indeed, it should simply get downloaded. The last resort is to simply run the Studio CE from the installer. It should fix all issues and download the 2018.4 after the first run.


#5

Last resort worked, installer helped and 2018.4 is now installed.

I will wait for new BETA to see if it will update automaticaly.

btw. love the dark theme! //BR Marek