Update to 17.1.6498 hammers workflows, two versions installed: SOLVED

studio

#1

Scenario: Community Edition updated to .6498

Steps to reproduce: None required, it updated itself

Current Behavior: .6435 still installed

Expected Behavior: .6435 would be removed.

Studio/Robot/Orchestrator Version:

Last stable behavior: .6435
Last stable version: .6498
OS Version: Win7 64-bit OS
Others if Relevant: (workflow, logs, .net version, service pack, etc):

This behavior seems odd, and many things are now not working with .6498. Everything works fine if I use .6435, however.

SOLVED:

  1. Rename C:\Users\Me\AppData\Local\UiPath\app-17.1.6435\UiStudio.exe to C:\Users\Me\AppData\Local\UiPath\app-17.1.6435\UiStudio.exe.old
  2. Rename C:\Users\Winter\AppData\Local\UiPath\app-17.1.6435\UiStudio.exe.config to C:\Users\Winter\AppData\Local\UiPath\app-17.1.6435\UiStudio.exe.config.old

EDIT: File association didn’t work after the process above, so I reinstalled.


#2

what happens?


#3

Hi M., thanks for getting back so quickly.
I rebooted and the errors are gone. Before I rebooted, I got the infamous "side-by-side configuration is incorrect."
Even after rebooting, I was getting selector errors when finding an image in a Word document.
Then I started up from the app-17.1.6435 directory and ran a few workflows, and the errors vanished. After opening them again in .6498, the errors are gone!

EDIT: When I run a workflow created in .6435 with .6498 it works fine. When I try to recreate the same workflow (albeit in the same project folder) with .6498, in this case working with a Word document, when trying to “indicate on screen” with a “Find Image” activity, I get the error “Cannot identify the element indicated on screen using selector generated at selection time.” This error pops up as soon as the Word document appears. I’m going to try to create another project folder and see if that helps.

EDIT: I created a new project and started up .6498. Although I can get everything to run now, occasionally when using “Type Into” an extraneous “%” is inserted before “[k(alt)]” & “jph4” & “[k(enter)]”, i.e. “%[k(alt)]” & “jph4” & “[k(enter)]”. Also, I have to concatenate the text as shown, instead of being able to “”[k(alt)]jph4[k(enter)]", which as I recall worked in .6435.

EDIT: The workflow is failing once again.

EDIT: I think there is interference between the two versions behind the scenes somewhere. The failing workflows have started working again. Perhaps it’s my system, but I’m still worried about an old version being left behind. Should I be?

Is it normal for the old version to be left behind? I suspect that what happened was I had one UiStudio.exe running, then started another instance that updated itself. Could that be?

Should I reinstall?

Regards,
burque505


#4

hi burque505, this is a known issue, but still thank you for the good information provided here.


#5

@Gabriel_Tatu, thanks a lot.

Regards,
burque505