Update SharePoint List Item functionality

Hello everyone,

Does anyone have practical experience with updating a field in a SharePoint list?

I have tried this tutorial.

Unfortunately I get the error message Update List Item: Code: invalidRequest Message: Invalid request.

The error is issued by the Update List Item activity.

Updating only one field in the item does not work either.

Package: UiPath.MicrosoftOffice365.Activities

1 Like

Can you share your workflow or error screenshot?

I can post the screenshots.
To reduce the sources of errors I have not made any changes to the item and only want to update. I have also tried the case with changed data.


Hi @Kytyzow ,
Haven’t been able to reproduce the same error. But maybe we can filter out some of the potential causes :

  • What is the 15th field about? What is the column type ?

  • Is the error reproduceable for other fields and with other values assigned?

  • As it is not visible on the screenshot, can you please confirm that in the “Assign” box you wrote ‘ListItem.Fields(15).Value’ ? or is a different input?

  • Can you please confirm your user has the permissions to edit the list items’ fields?

  • What package version do you use?

Thank you.

What is the 15th field? What is the column type?

  • It is a text field

Is the error reproducible with other fields and with other assigned values?

  • The error is not field related

As it is not visible on the screenshot, can you please confirm that you have written the value “ListItem.Fields(15).Value” in the “Assign” field, or is it a different input?

  • ListItem.Fields(15).Value

Can you please confirm that your user has permission to edit the list item fields?

  • Yes, the user has the permission.

Which package version are you using?

  • 1.11.1

Also, the workflow of just updating without making a modification will result in an error.


Were you able to resolve this error. We are having the same issue.


@Humidityhater , can you please share what is the type of the column you try to update, and what is the new value you try to assign?

Hi. I’m currently getting the same error ‘Invalid Request’ when trying to use the ‘Update List Item’ activity. To narrow things down I removed the activities that update the list item object locally and am just trying to update the original list item with its original values. Still getting this error. Any suggestions? I’m using version 1.11.1 of the activities.

Has anyone got a solution or workaround regarding this topic? Also facing the same problem