Unzip files older version cannot download non-UiPath packages

Hello Community!

I want to unzip files. I am on version 2018.4.6 and cannot upgrade or download packages that are not by UiPath.

How can I unzip?

Thank you!

Hi @Jessica_Moseley

If u are not able to download packages then u can try below

  1. How to zip files using invoke method?

  2. Use powershell for unzip the files (use invoke powershell activity for this )

Try these ways

Hope it helps you


Nived N :robot:

Happy Automation :relaxed::relaxed::relaxed::relaxed:

Thanks! I created zipFile and extractPath variables (both as String) but when I put the ZipFile.ExtractToDirectory(zipFile, extractPath) into the Invoke Power Shell activity, ExtractToDirectory does not appear after the period.

For Invoke Power Shell, the TypeArgument is system.management.automation.PSObject

unzip.xaml (5.8 KB)

The xaml attached is not from the 2018.4.6 version, it’s just for ease of understanding for the community. My previous limitations still apply ie. cannot download packages unless it’s by UiPath and version 2018.4.6.

Did u tried with powershell?

Yes and got the attached error. UiPath Error

have a look here:

The original docu reference find here:

kindly note: the netframework level 4.6.1 is to refer and NOT .net 5 (here the class is located within a different assembly)

HI @Jessica_Moseley,

Here is the package to zip file …

Video demonstration :

Thank you

I cannot download any packages that are not by UiPath.

I added it to notepad and still cannot find the Target Type. I only see CompressionLevel and CompressionMode as options for System.IO.Compression

@badita solved this in an earlier post!
I’m opening your workflow and I get this warning ’ ZipFile' does not have a public static method named 'ExtractToDirectory' matching the parameter types, generic type arguments, and generic type constraints supplied to InvokeMethod .

Basically you’re trying to call ZipFile.ExtracttoDirectory() instead of ZipFile.ExtractToDirectory(zipFile, extractPath)

After setting the parameters (zipPath, extractPath) for the ExtractToDirectory method it will work.

Aren’t you getting the same?

Thank you @NIVED_NAMBIAR and @ppr for your help!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.