Unwanted quotes in database text extraction

Hello, I am having a strange issue with some table to .txt process :

I do a SELECT on a DB (oracle, WE8MSWIN1252), then the activity “output data table”, then the “write text file” activity.

On my resulting .txt file, some rows (only a few) show double quotes before the 1st and after the last character of the row.

The problem seems to be about the extracting, because whichever encoding I choose, the quotes are still there.

Do you have any idea of a solution ?

Thank you :slight_smile:


It will be great if you provide with some screens


Just found that the character “,” is causing the problem. Still don’t know what to do with this


Here is the capture of the .txt result


Can you check is there any sort of difference in value which you are getting " " with other values in DB?

Also check is your output datatable is also showing the same?


I only get the quotes when there is the “,” character in the row. But I can’t just delete all the double quotes because some data contains these characters.

My output DT is not showing this issue (I tried to export it as .csv and there was no problem)

It looks like the transition to .txt file is causing the issue


You can use Encoding in write Text file activity

Give Encoding as utf-8 and try

Hope this may helps you


I tried again with the utf-8 encoding (tried with ANSI too), but the problem remains.

It seems that the “correction” the robot does is happening before the encoding

About the .csv file :
-opened in excel : no problem
-opened in text editor : same issue with the quotes

So the problem is in the output data table

I just checked my table variable before the Output data table activity :
The quotes are already present juste after the SELECT query.
Screenshot :

So when creating the DT variable, the robot puts the double quotes on the rows containing the “,” character…