Unlock Linux automation with 21.8 Robot!

Hi @Vinod_Bhatt,

Right now we support only Docker containers. The base image we are using is an Alpine Linux 3.13 with dotnet runtime installed.

If you are planning to make your own docker images, if you install the dotnet runtime, it should support any flavor base OS image.

Bes regards,
Andrei

1 Like

Hi @erghe, I tried that but I was unable to connect to the orchestrator. I’m using a self-signed certificate for the orchestrator. How do I make it trust the certificate?

Hi @rizistt,

This is not UiPath Robot specific, but Linux specific. If you have the rootCA.crt file you can use the following dockerfile to create a docker of your own that includes the self-signed certificate.

FROM registry.uipath.com/robot/runtime
ADD rootCA.crt /usr/local/share/ca-certificates/uipath.crt
RUN chmod 644 /usr/local/share/ca-certificates/uipath.crt && /usr/sbin/update-ca-certificates
ENTRYPOINT ["/root/application/startup.sh"]

The rootCA.crt certificate should be in the same folder as the Dockerfile and you should run the build command docker build -t myrobot-self-signed-cert . then run the new docker image that you have build using: docker run -e LICENSE_AGREEMENT=accept -e ORCHESTRATOR_URL="https://cloud.uipath.com/organization/tentant/orchestrator_" -e MACHINE_KEY="$KEY" -tid myrobot-self-signed-cert

Best regards,
Andrei

Thanks @erghe,

I did what you mentioned. Unfortunately, I was unable to get it up and running. I have attached the container logs for your kind information.

Any help would be appreciated.

Great…

Hi @erghe,

Re-installation of Docker Desktop did the trick. To be on the safe side, I updated the self-signed certificate and created a new image (as you mentioned above), and it worked.

I’m sure Linux + RPA will open so many new doors. Excited!!

Thank you!

3 Likes

We are proud to announce that the following UiPath IT Automation activity packages are now available for the Robot on Linux:

  • Amazon Web Services (AWS)
  • AWS Workspaces
  • Azure
  • Azure Virtual Desktop
  • Azure Active Directory
  • Google Cloud (GCP)
  • Citrix Hypervisor

The cross-platform UiPath IT Automation activities enable you to build automations for Cloud resources provisioning and management, ITSM and User Management, Desktop and App Virtualization, Server Virtualization.
Stay tuned for updated examples on github and on UiPath Marketplace.

6 Likes

Great opportunities you have provided here. Thank you for that.

Unfortunately, I get stuck at one point. There are unattended sessions on my Docker-Machine visible in Orchestrator. But configured Robots do not connect. What can be the reason for that? On one screenshot I can see that you use Domain/Username, is that correct. And if so, what
credential type is to use?

Best regards Ray

Hi @Ray_Mueller,

Can you please provide me a screenshot on the Orchestrator and the logs from the Robot?

We changed the login method for unattended robots on Linux and we now support executing jobs on the Linux Robot without credentials.

Best regards,
Andrei

Hello Andrei, I’ll try my best.

Best regards,

Ray

I guess it’s adding \n\r (which means a return - essentially a new line) at the end of the URI.

Thanks for your answer. Should I change this:

ORCHESTRATOR_URL=“https://cloud.uipath.com/orgname/DefaultTenant/orchestrator_”?

Hi @Ray_Mueller,

Yes, that is the correct format for your orchestrator URL. It should be like this image

Best regards,
Andrei

I am confused. The format used is not correct, but the unattended sessions are in status connected.

Can you please explain credentials-less robots a bit more.

A post was split to a new topic: Learning advise for a beginner

Hi @Ray_Mueller,

You are using classic folders and this is why the Robot shows it is Disconnected. The Linux and credential-less Robots are to be used with Modern folders.

Best regards,
Andrei

1 Like

@erghe

Hi, it works!

1 Like

Hi everyone,

We published a github repository where you can check how to build a docker container that uses our UiPath Robot and Java/Python environment or the self-signed certificate from your private Orchestrator.

Best regards,
Andrei

2 Likes

Nice, thanks for sharing!

-Eero