Unlock Linux automation with 21.8 Robot!

Thanks for the clarification.
So just docker start and docker stop commands are more than enough and the GUID is just a response.

Will be exciting to try this on arm.

Hi @jeevith,

Just to clarify this, as you can see in the image below, you need to specify which container to stop or start using the Container ID taken from the docker ps -a command. The ID you get is a response from the docker engine in order to confirm that the previous command was executed correctly.

You can check the docker documentation at docker start | Docker Documentation


1 Like

Hi @erghe,

I got what you said with respect to the containerID which is 12 char string. The GUID I was pointing to earlier was

But as you said this is just a response from docker and all one needs to ensure is find the containerID of the UiPath Image (registry.uipath.com/robot/runtime) and use the start and stop commands in Docker as shown in the documentation

Just for fun, I have some ideas to integrate Linux Automation with Webtop by modifying the Docker Compose file. Docker running Linux on webbrowser running Docker running the UiPath robot. Close to inception!

Will share my findings if I manage to get it to work :slight_smile:


Very cool news! Looking forward to hearing more about Linux + UiPath working together!

1 Like

Awesome news - Can’t wait to try this out. Great work to all teams involved in delivering Linux Automation and Automation Suite. Thanks


This is super awesome!!! Will surely try this out to see the new experience :slight_smile:


Finally the team will be excited since we have some use cases with Linux. We will review and see if we can start something to review the usage on Linux.

wow. this will big impact for the cost.

It’s great news that Uipath support container platform. Kudos to the team.
Few questions:

  1. Which container tech Uipath support (Openshift, EKS, etc)
  2. When we create docker image, does it support any linux flavor base OS image (redhat or ubantu, etc)?
1 Like

Hi @Vinod_Bhatt,

Right now we support only Docker containers. The base image we are using is an Alpine Linux 3.13 with dotnet runtime installed.

If you are planning to make your own docker images, if you install the dotnet runtime, it should support any flavor base OS image.

Bes regards,

1 Like

Hi @erghe, I tried that but I was unable to connect to the orchestrator. I’m using a self-signed certificate for the orchestrator. How do I make it trust the certificate?

Hi @rizistt,

This is not UiPath Robot specific, but Linux specific. If you have the rootCA.crt file you can use the following dockerfile to create a docker of your own that includes the self-signed certificate.

FROM registry.uipath.com/robot/runtime
ADD rootCA.crt /usr/local/share/ca-certificates/uipath.crt
RUN chmod 644 /usr/local/share/ca-certificates/uipath.crt && /usr/sbin/update-ca-certificates
ENTRYPOINT ["/root/application/startup.sh"]

The rootCA.crt certificate should be in the same folder as the Dockerfile and you should run the build command docker build -t myrobot-self-signed-cert . then run the new docker image that you have build using: docker run -e LICENSE_AGREEMENT=accept -e ORCHESTRATOR_URL="https://cloud.uipath.com/organization/tentant/orchestrator_" -e MACHINE_KEY="$KEY" -tid myrobot-self-signed-cert

Best regards,

Thanks @erghe,

I did what you mentioned. Unfortunately, I was unable to get it up and running. I have attached the container logs for your kind information.

Any help would be appreciated.


Hi @erghe,

Re-installation of Docker Desktop did the trick. To be on the safe side, I updated the self-signed certificate and created a new image (as you mentioned above), and it worked.

I’m sure Linux + RPA will open so many new doors. Excited!!

Thank you!


We are proud to announce that the following UiPath IT Automation activity packages are now available for the Robot on Linux:

  • Amazon Web Services (AWS)
  • AWS Workspaces
  • Azure
  • Azure Virtual Desktop
  • Azure Active Directory
  • Google Cloud (GCP)
  • Citrix Hypervisor

The cross-platform UiPath IT Automation activities enable you to build automations for Cloud resources provisioning and management, ITSM and User Management, Desktop and App Virtualization, Server Virtualization.
Stay tuned for updated examples on github and on UiPath Marketplace.


Great opportunities you have provided here. Thank you for that.

Unfortunately, I get stuck at one point. There are unattended sessions on my Docker-Machine visible in Orchestrator. But configured Robots do not connect. What can be the reason for that? On one screenshot I can see that you use Domain/Username, is that correct. And if so, what
credential type is to use?

Best regards Ray

Hi @Ray_Mueller,

Can you please provide me a screenshot on the Orchestrator and the logs from the Robot?

We changed the login method for unattended robots on Linux and we now support executing jobs on the Linux Robot without credentials.

Best regards,

Hello Andrei, I’ll try my best.

Best regards,


I guess it’s adding \n\r (which means a return - essentially a new line) at the end of the URI.