Unique Scenario: Set Text unable to set complete string

Hi All,

I am automating a timesheet web based app and need to use the set text to key in the WBS entry. However “Set Text” seems to miss some characters. For e.g. the text “C.2279.B01.01” is entered as “C.227.B01.01” in the web element by Set Text .Since “9” is missing , that particular timesheet entry fails.
Has anyone come across a problem similar to this?

Hi @Janardhanan,

Can you use Type into activity if set text is not working.

Because i have used set text and with the above string i tried to put in some text box and it was successfull

1 Like

HI @Janardhanan

Have you tried using the Type Into activity? This should work for you…

let know how it goes

oops… looks like Anil & I gave the same answer at the same time :slight_smile:

1 Like

Hi Anil,Fernando,

Thanks for your responses. Yes, the Type Into works fine and does not produce the same error. But wanted to check if it was generic error as Set Text is the main Activity used in the POC we are building,Replacing Set Text everywhere with Type Info would be troublesome .

Hi @Janardhanan,

I have used set text and your same string i type in google it worked, can you perform the same operation and let us know if its working.

So this issue is happening for each set text, or particularly in this scenario of “C.2279.B01.01”

See every time you cannot use Set text, set text is similar to how type into works with simulate property so there will be few issues which using set text.

Hi Anil,

Yes, the set text works fine with web elements on other sites .Seem the problem only appears in web elements in the SAP timesheet application . The problem occurs not just with this string but any string with 9 in it. On some other systems, even type into is having issues with the “.” being missed out.