Unexplained 1 minute delay to detect web elements

When trying to click on web based elements, it always takes 1 minute for the activity to start executing, even though the ‘delayBefore’ value is empty.
The execution always takes exactly 00:01:01 , which I assume means that it waits for a minute to start detecting the element. This is despite me letting the element/page load fully and starting this activity only after a long time after the element has loaded.
Does anyone know why?
I have attached the screenshot and xaml file.

rough use.xaml (6.5 KB)


Hi @Athrix05,

can you provide the webside Url and which one you are trying to click.?

for each and every activity default timeout is 30 sec.



It is an SAP link and unfortunately the link isn’t accessible outside company network. But I am sure it is not a problem with particular sites, because I have observed the same issue with Microsoft Office Planner site too.

And I have not changed the default ‘TimeOut’ value either. So if it is an issue with detecting the element, I should get an error once the default 30 secs elapse.

But everytime, the process takes 00:01:01 time to complete, which means it detects the element and waits 1 minute before executing the click action.
Any ideas?

Try changing the WaitForReady property to ‘None’. If this is causing issues because it is interacting with the website too early, you can remedy that by adding a short Delay activity beforehand, or by adding an On Element Appear activity beforehand.

Also, do you know what browser is being used? Others have had issues with delays (usually 180seconds though) whenever a download message pops up at the bottom of IE11.

1 Like

I am using IE 11 on Win10. And I can confirm that the WaitForReady value is still empty and as per your advice I will try changing that to 0.

However, I am running a workflow where the ONLY activity is the ‘Click’ activity and I am totally sure that the element has loaded up completely even before I run the workflow, so the WaitForReady property shouldn’t really matter right?

Also thanks for the heads-up on the delay of 180 secs due to download message. Will avoid that too.

Any other ideas as to why I am facing this 1 minute delay?

The WaitForReady attribute can be either ‘None’, ‘Interactive’, or ‘Complete’. You can find it in the Click activity by clicking on the + sign by Target within the properties window.

Try putting it on ‘None’. It may look like all elements are loaded/interactive, but for whatever reason the robot doesn’t realize it. Setting it to ‘None’ will have the robot perform the Click activity immediately